css3 transitions are sometimes jerky

RESOLVED DUPLICATE of bug 822231

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 822231
5 years ago
5 years ago

People

(Reporter: julienw, Assigned: nrc)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:
* go to http://everlong.org/mozilla/animation/transition.html
* click on "trigger the animation"

Expected:
* the animation is fluid

Actual:
* the animation is sometimes fluid, sometimes jerky.

Note: it's often more jerky at the first animation. If you hit reset and then trigger again, it's never as jerky.

This maybe the same problem as in Bug 822231, but I'm not sure.
(Reporter)

Comment 1

5 years ago
Flipping the preference "layers.offmainthreadcomposition.animate-transform" to false make the problem go away, as in Bug 822231.

I know this is most probably a different bug though.
(Assignee)

Updated

5 years ago
Assignee: nobody → ncameron
(Assignee)

Comment 2

5 years ago
Hmm, so it seems that starting at scale=0 is causing the problem here. The smaller the starting scale the more broken the transition becomes. But 0 seems to be a special case. I'm not sure why this should only affect us when throttling is on and not just regular OMTA, but I'm guessing it is because without throttling the compositor gets kept inline with regular redraws from layout.
(Assignee)

Comment 3

5 years ago
The fix I'm working on for 822231 fixes this problem, so I am convinced they are the same bug (actually 822231 is a little bit more complex than this one, only patch 2 is required to fix this bug).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 822231
You need to log in before you can comment on or make changes to this bug.