Closed Bug 822290 Opened 7 years ago Closed 6 years ago

Intermittent devtools/responsivedesign/test/browser_responsivecomputedview.js | Test timed out | Found a tab...

Categories

(DevTools :: Inspector, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 825427

People

(Reporter: emorley, Assigned: bbenvie)

References

Details

Attachments

(1 file)

Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-browser-chrome on 2012-12-15 18:45:07 PST for push 2c2f92101a69

slave: talos-r3-xp-081

https://tbpl.mozilla.org/php/getParsedLog.php?id=17987707&tree=Mozilla-Inbound

{
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsive_cmd.js | Finish
MOZ_EVENT_TRACE sample 1355626988687 832
console.warn: Failed to remove handler from Inputter.onResize
console.warn: Failed to remove handler from CommandAssignment.onAssignmentChange
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsive_cmd.js | finished in 483ms
TEST-INFO | checking window state
TEST-START | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | Console message: [JavaScript Warning: "Selector expected.  Ruleset ignored due to bad selector." {file: "data:text/html,<html><style>div%20{%20%20width:%20500px;%20%20height:%2010px;%20%20background:%20purple;}%20@media%20screen%20and%20(max-width:%20200px)%20{%20%20div%20{%20%20%20%20%20width:%20100px;%20%20}};</style><div></div></html>" line: 1}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | Console message: [JavaScript Warning: "Unexpected end of file while searching for closing } of invalid rule set." {file: "data:text/html,<html><style>div%20{%20%20width:%20500px;%20%20height:%2010px;%20%20background:%20purple;}%20@media%20screen%20and%20(max-width:%20200px)%20{%20%20div%20{%20%20%20%20%20width:%20100px;%20%20}};</style><div></div></html>" line: 1}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html><style>div%20{%20%20width:%20500px;%20%20height:%2010px;%20%20background:%20purple;}%20@media%20screen%20and%20(max-width:%20200px)%20{%20%20div%20{%20%20%20%20%20width:%20100px;%20%20}};</style><div></div></html>" line: 0}]
MOZ_EVENT_TRACE sample 1355626989000 177
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | instance of the module is attached to the tab.
MOZ_EVENT_TRACE sample 1355626989125 79
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | Console message: [JavaScript Warning: "XUL box for hbox element contained an inline span child, forcing all its children to be wrapped in a block." {file: "resource://gre/modules/devtools/Highlighter.jsm" line: 433}]
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | Got inspector instance
MOZ_EVENT_TRACE sample 1355626989203 95
MOZ_EVENT_TRACE sample 1355626989281 159
MOZ_EVENT_TRACE sample 1355626989406 158
MOZ_EVENT_TRACE sample 1355626989453 129
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | We have access to the Computed View object
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | Should show 500px initially.
MOZ_EVENT_TRACE sample 1355626989531 134
MOZ_EVENT_TRACE sample 1355626989796 138
MOZ_EVENT_TRACE sample 1355626989937 111
MOZ_EVENT_TRACE sample 1355626990203 132
MOZ_EVENT_TRACE sample 1355626990343 137
MOZ_EVENT_TRACE sample 1355626990484 123
MOZ_EVENT_TRACE sample 1355626990625 120
MOZ_EVENT_TRACE sample 1355626990781 136
MOZ_EVENT_TRACE sample 1355626990921 139
MOZ_EVENT_TRACE sample 1355626991078 213
MOZ_EVENT_TRACE sample 1355626991234 201
MOZ_EVENT_TRACE sample 1355626991375 145
MOZ_EVENT_TRACE sample 1355626991500 136
MOZ_EVENT_TRACE sample 1355626991640 145
MOZ_EVENT_TRACE sample 1355626991796 161
MOZ_EVENT_TRACE sample 1355626991937 148
MOZ_EVENT_TRACE sample 1355626992078 143
MOZ_EVENT_TRACE sample 1355626992203 143
MOZ_EVENT_TRACE sample 1355626992343 136
MOZ_EVENT_TRACE sample 1355626992484 156
MOZ_EVENT_TRACE sample 1355626992625 108
MOZ_EVENT_TRACE sample 1355626992765 143
MOZ_EVENT_TRACE sample 1355626992906 120
MOZ_EVENT_TRACE sample 1355626993062 155
MOZ_EVENT_TRACE sample 1355626993203 153
MOZ_EVENT_TRACE sample 1355626993328 141
MOZ_EVENT_TRACE sample 1355626993484 149
MOZ_EVENT_TRACE sample 1355626993734 568
MOZ_EVENT_TRACE sample 1355626993875 141
MOZ_EVENT_TRACE sample 1355626994015 142
MOZ_EVENT_TRACE sample 1355626994156 150
MOZ_EVENT_TRACE sample 1355626994781 2235
MOZ_EVENT_TRACE sample 1355626998812 107
MOZ_EVENT_TRACE sample 1355626998953 142
MOZ_EVENT_TRACE sample 1355626999187 109
MOZ_EVENT_TRACE sample 1355626999328 114
MOZ_EVENT_TRACE sample 1355626999468 153
MOZ_EVENT_TRACE sample 1355626999609 141
MOZ_EVENT_TRACE sample 1355626999765 182
MOZ_EVENT_TRACE sample 1355626999906 146
MOZ_EVENT_TRACE sample 1355627000046 146
MOZ_EVENT_TRACE sample 1355627000187 155
MOZ_EVENT_TRACE sample 1355627000328 152
MOZ_EVENT_TRACE sample 1355627000468 152
MOZ_EVENT_TRACE sample 1355627000609 138
MOZ_EVENT_TRACE sample 1355627000750 147
MOZ_EVENT_TRACE sample 1355627000890 148
MOZ_EVENT_TRACE sample 1355627001031 116
MOZ_EVENT_TRACE sample 1355627001171 110
MOZ_EVENT_TRACE sample 1355627001312 155
MOZ_EVENT_TRACE sample 1355627001453 151
MOZ_EVENT_TRACE sample 1355627001593 140
MOZ_EVENT_TRACE sample 1355627001734 117
MOZ_EVENT_TRACE sample 1355627001875 110
MOZ_EVENT_TRACE sample 1355627002015 153
MOZ_EVENT_TRACE sample 1355627002296 669
MOZ_EVENT_TRACE sample 1355627002437 129
MOZ_EVENT_TRACE sample 1355627002593 210
MOZ_EVENT_TRACE sample 1355627003468 2749
MOZ_EVENT_TRACE sample 1355627007500 97
MOZ_EVENT_TRACE sample 1355627007640 142
MOZ_EVENT_TRACE sample 1355627007890 150
MOZ_EVENT_TRACE sample 1355627008031 141
MOZ_EVENT_TRACE sample 1355627008171 147
MOZ_EVENT_TRACE sample 1355627008312 143
MOZ_EVENT_TRACE sample 1355627008453 148
MOZ_EVENT_TRACE sample 1355627008593 143
MOZ_EVENT_TRACE sample 1355627008843 529
MOZ_EVENT_TRACE sample 1355627008984 160
MOZ_EVENT_TRACE sample 1355627009421 663
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsivecomputedview.js | Test timed out
}
Blocks: 820315
Looking at the screenshot, apparently, the computed view is not selected.
Attached patch patch v1Splinter Review
I'm not 100% sure this will fix this intermittent. Let's see if it calms down the oranges.
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #726547 - Flags: review?(jwalker)
Comment on attachment 726547 [details] [diff] [review]
patch v1

Review of attachment 726547 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with a comment on the use of executeSoon (or its removal)

::: browser/devtools/responsivedesign/test/browser_responsivecomputedview.js
@@ -24,5 @@
>      "@media screen and (max-width: 200px) {" +
>      "  div { " +
>      "    width: 100px;" +
>      "  }" +
> -    "};" +

do we need this change?

@@ +64,3 @@
>        inspector.selection.setNode(div);
>      });
> +    executeSoon(function() {

Perhaps we should get into the habit of insisting on source comments for all uses of executeSoon. I think this is worth a comment.
Attachment #726547 - Flags: review?(jwalker) → review+
This seems to have spiked since bug 943510 landed. It's also one we're hitting fairly regularly on Cedar with the devtools tests split out and chunked.
Flags: needinfo?(bbenvie)
It looks like this patch has bitrotted and the way it attempts to fix the problem probably wouldn't have been successful in fixing the intermittent (since the changes that landed account for timing issues with opening the computed view).
Assignee: paul → bbenvie
Flags: needinfo?(bbenvie)
Same failure as for bug 825427. I will be fixing both at the same time.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 825427
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.