Closed Bug 822422 Opened 7 years ago Closed 7 years ago

Firefox wordmark barely visible on dark lightweight themes

Categories

(Firefox for Android :: Theme and Visual Design, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 20
Tracking Status
firefox19 --- verified
firefox20 --- verified

People

(Reporter: sriram, Assigned: sriram)

References

Details

Attachments

(2 files)

The Firefox wordmark is barely visible on dark lightweight themes. We need different set of resources that would work on light and dark themes (in addition to default one).
Blocks: themes
Flags: needinfo?(ibarlow)
We'll need a white Firefox wordmark for this. CC-ing Eric.
Flags: needinfo?(ibarlow)
Sized for mdpi, hdpi and xhdpi.  let me know if anything else is needed, thx!
Assignee: nobody → sriram
Attached patch PatchSplinter Review
White on dark. Black on light. All good. :D
Attachment #693636 - Flags: review?(mark.finkle)
Attachment #693636 - Flags: review?(mark.finkle) → review+
I had triggered a clobber for the same. It's a clobbering issue.
(In reply to Sriram Ramasubramanian [:sriram] from comment #6)
> I had triggered a clobber for the same. It's a clobbering issue.

Ah, sorry.

Our mobile build story is so messed up :-(
https://hg.mozilla.org/mozilla-central/rev/7ecc2913a1e6
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Comment on attachment 693636 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Personas.
User impact if declined: Firefox watermark will be in grey on a dark theme, and barely visible.
Testing completed (on m-c, etc.): Landed on m-c yesterday.
Risk to taking this patch (and alternatives if risky): Very low. Just addition of few images in this patch.
String or UUID changes made by this patch: None.
Attachment #693636 - Flags: approval-mozilla-aurora?
Attachment #693636 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Firefox 20.0a1 (20123-01-02)
Device: Galaxy Nexus 
OS: Android 4.1.1 

I can see the white wordmark using the theme : https://addons.mozilla.org/en-US/android/addon/a-festival-of-lights-pink-f/  Bug is verified on Nightly. Please push this to aurora and I will mark this verified after checking it on Firefox 19 too
Firefox 19 Beta 1 (2013-01-08)
Device: Galaxy Nexus
OS:Android 4.1.

This was push in beta channel also as Firefox 19 is currently in Beta. As the wordmark is white now I will mark the bug Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.