Status

()

RESOLVED DUPLICATE of bug 725156
6 years ago
6 years ago

People

(Reporter: jared.wolinsky, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

Steps to reproduce:

Tested using both Firefox 17.01 and the latest nightly build, I opened a file containing the following code: http://pastebin.com/WQLT64xe.  Next I attempted to click and drag various spots within the <th> column header cells.


Actual results:

The value (0) in the <span> at the top of the page did not change when I dragged the <th> elements.


Expected results:

The drag event should fire when the user clicks and drags a <th> element.  The handler should cause the <span> at the top to be updated with the relative X position of the mouse each time the mouse moves while dragging. I confirmed this behavior works as expected in Chrome.
Component: Untriaged → DOM: Events
Product: Firefox → Core

Updated

6 years ago
Component: DOM: Events → Drag and Drop

Comment 1

6 years ago
event fired but coordinate is always 0.
This should be duplication of Bug 505521

Comment 2

6 years ago
 And also you should set data to event.dataTransfer  on dragstart.

Comment 3

6 years ago
In addition, this should be duplication of bug 725156
(Reporter)

Comment 4

6 years ago
Yeah, after I called event.dataTransfer.setData on dragstart, the drag event fired. It looks like a duplicate of those two bugs indeed.
Jared, thanks for reporting this. I'm setting it as a duplicate of 725156 as Alice0775 White suggested.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 725156
You need to log in before you can comment on or make changes to this bug.