Closed Bug 822507 Opened 8 years ago Closed 8 years ago

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+)

RESOLVED FIXED
B2G C3 (12dec-1jan)
blocking-basecamp +

People

(Reporter: nhirata, Assigned: djf)

References

Details

(Keywords: regression)

Attachments

(1 file)

As reported by Yamamoto-san:

"I founded a lack of JavaScript file on Gallery app.

open.html requires "frame.js"

 <script type="text/javascript" defer src="js/Frame.js"></script>
see: https://github.com/mozilla-b2g/gaia/blob/master/apps/gallery/open.html

but, js directory have no "fame.js".
So, if we use intent for gallery, process will be stop."

I did a find . -name Frame.js and I couldn't find a file at all.  There was nothing in the gallery/js directory

I don't think this stops when the intent is called by the camera app.  I am not sure what the reprocussion is.
Oops!

I moved gallery/js/Frame.js to shared/js/media/MediaFrame.js when I added native previews to the Camera app. And I forgot about the Gallery's Open activity when I did it.

The open activity must not get used much because it has been more than a week and the bug has not been noticed... Still, opening images from other apps is now completely broken.

This is a one line, risk-free bug to fix.

Nominating blocking.
Assignee: nobody → dflanagan
blocking-basecamp: --- → ?
Blocks: 815079
The user-visible effect of this bug is that when you receive an image via bluetooth you can't view it.  I need to fix it and have marked this bug as blocking the blocking+ bug 815079.

The two-line fix is coming up.
Attachment #693598 - Flags: review?(dale)
Attachment #693598 - Flags: review?(dale) → review+
Comment on attachment 693598 [details]
link to patch on github

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 812924
User impact if declined: images transferred via bluetooth can't be previewed
Testing completed: yes
Risk to taking this patch (and alternatives if risky): zero risk: its a two line patch that changes a script filename and the name of one constructor.  I forgot to update open.html and open.js when I implemented native previews for the camera for bug 812924.
Attachment #693598 - Flags: approval-gaia-master?(21)
blocking-basecamp: ? → +
Keywords: regression
Priority: -- → P2
Target Milestone: --- → B2G C3 (12dec-1jan)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 693598 [details]
link to patch on github

We got blocking plus and landed this, so cancelling the approval-gaia-master request.
Attachment #693598 - Flags: approval-gaia-master?(21)
You need to log in before you can comment on or make changes to this bug.