Closed Bug 822509 Opened 7 years ago Closed 2 years ago

If you're scrolling settings-menu and you happen to start your scroll by pressing a slider-knob, you'll dynamically adjust the slider as you scroll the settings-menu, if you scroll diagonally

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.6?, blocking-basecamp:-, tracking-b2g:backlog)

RESOLVED WONTFIX
blocking-b2g 2.6?
blocking-basecamp -
tracking-b2g backlog

People

(Reporter: dholbert, Unassigned)

References

Details

(Keywords: b2g-testdriver, unagi)

STR:
 1. Go to Settings | Sound
 2. Now, scroll down -- BUT -- begin your scroll by pressing somewhere in the "Ringer & Notifications" line (and then dragging up or down).  Don't release your finger.
 3. While you're scrolling (or maybe at the end of your scroll), drag side-to-side.

EXPECTED RESULTS: Ringer & Notifications volume-level remains un-changed
ACTUAL RESULTS: Ringer & Notifications volume level is adjusted as I scroll. (possibly jumping to 0% or 100% depending on how I do it)
Sound slider isn't a real slider.  You have to tap to where you want to select.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 802208
Un-duping - I think Comment 1 sounds like it misunderstands the bug being reported. (Feel free to re-dupe if I'm misunderstanding in turn.)

> Sound slider isn't a real slider.  You have to tap to where you want to select.

The point is, I *don't want* to adjust the slider -- in the STR, I'm *trying* to just scroll the settings menu.  But if I happen to start that scroll action from touching the slider, I end up adjusting the slider position when I don't want to.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
WORKSFORME, please retry with recent build.
blocking-basecamp: ? → -
I can repro with my own B2G trunk build (built from cloning https://github.com/mozilla-b2g/B2G and following the steps there -- I believe that pulls down trunk gaia as well).

Howwever, one clarification to the STR:
(In reply to Daniel Holbert [:dholbert] from comment #0)
>  2. Now, scroll down -- BUT -- begin your scroll by pressing somewhere in
> the "Ringer & Notifications" line (and then dragging up or down).

I can actually only reproduce the bug if I begin the scroll by touching the actual slider-knob itself. (not just an arbitrary point on the line)

That makes this significantly less likely to be triggered accidentally -- so, while I don't believe this is WFM, I agree that blocking- is appropriate.
Summary: If you're scrolling settings-menu and you happen to start your scroll by pressing a slider, you'll adjust the slider as you scroll the settings-menu → If you're scrolling settings-menu and you happen to start your scroll by pressing a slider-knob, you'll dynamically adjust the slider as you scroll the settings-menu, if you scroll diagonally
Duplicate of this bug: 971133
Nominate since its a frequently demand UX issue
blocking-b2g: --- → 2.6?
We could replace current slider with gaia-slider and fix related issues there
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 7 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.