CSS: {hyphens:auto;} no longer works in FF17

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: cilantropig, Unassigned)

Tracking

({testcase})

17 Branch
x86_64
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Added CSS rule
p{
       word-wrap: break-word;
       -webkit-hyphens: auto;
        -moz-hyphens: auto;
	hyphens: auto;
}


Actual results:

Added very long word in html, load html in FF17.
No hyphens are added when shrink down browser width.


Expected results:

In FF10, when shrink down browser width hyphens are added, long word breaks by hyphens and wraps correctly.
Could you please attach a complete testcase ?
Flags: needinfo?(cilantropig)
Keywords: testcase-wanted
(Reporter)

Comment 2

6 years ago
Created attachment 694393 [details]
load chatarea.html and narrow the borrow to see that auto hypen does not kick in
Flags: needinfo?(cilantropig)
You need an explicit 'lang' attribute.
Blocks: 702121
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: Untriaged → Style System (CSS)
Keywords: testcase-wanted → testcase
Product: Firefox → Core
Resolution: --- → INVALID
... because http://dev.w3.org/csswg/css3-text/#hyphens says:

Correct automatic hyphenation requires a hyphenation resource appropriate to the language of the text being broken. The UA is therefore only required to automatically hyphenate text for which the author has declared a language (e.g. via HTML lang or XML xml:lang) and for which it has an appropriate hyphenation resource.
Added a sentence on https://developer.mozilla.org/en-US/docs/CSS/hyphens to make this clear.
You need to log in before you can comment on or make changes to this bug.