[FTU UX VD] Change final illustration of the hand

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: vicky, Assigned: fcampo)

Tracking

({polish})

unspecified
x86
macOS
polish

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

(Whiteboard: Visual Design, UXBRANCH, [EU_TPE_TRIAGED], landed in uxbranch)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 693293 [details]
this is the new image to replace the existing

In the final dark grey screen of FTU, before the tutorial, change the illustration of the hand that is touching a circle for the one attached of the hand pointing right (as an indicator of continuity)
(Reporter)

Comment 1

6 years ago
Created attachment 693294 [details]
This is the screen where it should be placed
(Reporter)

Updated

6 years ago
Assignee: nobody → fernando.campo
Keywords: polish
Whiteboard: Visual Design
(Assignee)

Updated

6 years ago
blocking-b2g: --- → tef?
(Assignee)

Comment 2

6 years ago
Created attachment 701847 [details]
https://github.com/mozilla-b2g/gaia/pull/7598

Asset change, no risk
Attachment #701847 - Flags: review?(fbsc)
This is not a blocker but nice to have to be either tracked or implemented though the UX branch
blocking-b2g: tef? → -
tracking-b2g18: --- → +
Whiteboard: Visual Design → Visual Design, UXBRANCH, [EU_TPE_TRIAGED]
(Assignee)

Comment 4

6 years ago
Comment on attachment 701847 [details]
https://github.com/mozilla-b2g/gaia/pull/7598

asset change, safe land
Attachment #701847 - Flags: approval-gaia-master?(francisco.jordano)
No problem to accept this, is just an asset and the PR is already done.

For future changes like this (just an asset or changes in the markup or css), please use the UX branch.
(Assignee)

Comment 6

6 years ago
Created attachment 702971 [details]
https://github.com/gordonbrander/gaia/pull/93

Updating the PR to the UX-branch
Attachment #701847 - Attachment is obsolete: true
Attachment #701847 - Flags: review?(fbsc)
Attachment #701847 - Flags: approval-gaia-master?(francisco.jordano)
Attachment #702971 - Flags: review?(fbsc)
Landed in uxbranch: https://github.com/gordonbrander/gaia/commit/b2ffeabdee278a996c197f1bf0443dc92cd74cb6
Whiteboard: Visual Design, UXBRANCH, [EU_TPE_TRIAGED] → Visual Design, UXBRANCH, [EU_TPE_TRIAGED], landed in uxbranch
(Assignee)

Updated

6 years ago
Attachment #702971 - Flags: review?(fbsc)
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
My understanding is that a bug isn't RESOLVED->FIXED until it lands on gaia master branch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hi Fernando or Sam, can you land the patch in master? 

As there is no clear answers about the UX branch purpose right now, it'd be better to land it in master so after that, we can ask for uplifting the patch to v1-train. Otherwise I am afraid the work done will be lost and it will not land in time or never in the commercial release v1.1.
https://github.com/mozilla-b2g/gaia/commit/25d9e53380db967d76223c5f1e1940ed907ed447
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
On Master

Master build : 2013-03-26-07-02-04
"mozilla-central" revision="28b048ffb7a7"
"integration/gaia-central" revision="44f6a17f24d4"
"gecko.git"revision="a800f14ea7022a78966f7fe14a9b0d11c569b151"
"gaia.git" revision="ace1eb32a313da1232bbdf9cff2581a4b036356d"

Not on v1 train.
Status: RESOLVED → VERIFIED
status-b2g18: --- → affected
(Assignee)

Comment 12

6 years ago
Comment on attachment 702971 [details]
https://github.com/gordonbrander/gaia/pull/93

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: image consistency on tutorial will be affected, as the current image is different than the others
Testing completed: 
Risk to taking this patch (and alternatives if risky): low, assets change only
String or UUID changes made by this patch:
Attachment #702971 - Flags: approval-gaia-v1?
Attachment #702971 - Flags: approval-gaia-v1? → approval-gaia-v1+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 25d9e53380db967d76223c5f1e1940ed907ed447
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(fernando.campo)
(Assignee)

Comment 14

6 years ago
I checked it and saw that the conflicts are on the settings and browser app code, which are not touched on this bug. Probably because the used commit combines different UX fixes for different bugs.
I could try to solve the conflicts, but I'm not familiar with the code from those apps, nor the bugs they are trying to fix.

Or maybe it's easier to uplift the commit related to the bug (https://github.com/mozilla-b2g/gaia/commit/23aa5cd)
Flags: needinfo?(fernando.campo) → needinfo?(jhford)
Yes the master commit hash is 23aa5cd.
v1-train: d90de846f846898c9a1ecf591367b970fee6cac4

Wow, that's confusing!  is the rest of what was approved here actually approved?
status-b2g18: affected → fixed
Flags: needinfo?(jhford)
You need to log in before you can comment on or make changes to this bug.