Closed Bug 822596 Opened 9 years ago Closed 9 years ago

Stop using Google calendar schedules in TBPL

Categories

(Tree Management Graveyard :: TBPL, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: emorley)

References

Details

(Keywords: sheriffing-P2)

Attachments

(5 files)

* The sheriff schdule isn't used (and we've not going to be using the sheriffing site any time soon), causing confusion.
* It causes bug 764801 on Opera.
* It often causes TBPL to fail to load correctly, when Google is having a bad day (bug 821363 and more that were never filed since transient).

The above have been driving me nuts for months and yet again today TBPL is misbehaving due to Google calendar issues:

[11:24:29.596] SyntaxError: test for equality (==) mistyped as assignment (=)? @ https://www.google.com/uds/api/gdata/1.10/208a907929e7936990d2bf48205aa8d8/core,mediarss,opensearch,geo,atom,threading,app,gdata,maps,gbase,finance,blogger,contacts,analytics,acl,calendar,default.I.js:12
[11:24:29.597] SyntaxError: test for equality (==) mistyped as assignment (=)? @ https://www.google.com/uds/api/gdata/1.10/208a907929e7936990d2bf48205aa8d8/core,mediarss,opensearch,geo,atom,threading,app,gdata,maps,gbase,finance,blogger,contacts,analytics,acl,calendar,default.I.js:23
[11:24:29.597] SyntaxError: test for equality (==) mistyped as assignment (=)? @ https://www.google.com/uds/api/gdata/1.10/208a907929e7936990d2bf48205aa8d8/core,mediarss,opensearch,geo,atom,threading,app,gdata,maps,gbase,finance,blogger,contacts,analytics,acl,calendar,default.I.js:39
[11:24:29.598] SyntaxError: test for equality (==) mistyped as assignment (=)? @ https://www.google.com/uds/api/gdata/1.10/208a907929e7936990d2bf48205aa8d8/core,mediarss,opensearch,geo,atom,threading,app,gdata,maps,gbase,finance,blogger,contacts,analytics,acl,calendar,default.I.js:63
[11:24:29.599] SyntaxError: test for equality (==) mistyped as assignment (=)? @ https://www.google.com/uds/api/gdata/1.10/208a907929e7936990d2bf48205aa8d8/core,mediarss,opensearch,geo,atom,threading,app,gdata,maps,gbase,finance,blogger,contacts,analytics,acl,calendar,default.I.js:97

We should just strip out the Google calendar integration for now and for the buildduty schedule, just link to the Google calendar.
(Since you indicated you might be interested in working on TBPL once it was in it's own repo... :P)

If we're not using the calendar, 'staticSheriff' is no longer accurate, since they'll all be static.
Attachment #693348 - Flags: review?(jhammel)
We have no need to generate it in the same block that sets the tree open/closed/approval required status; no idea why it was put there.
Attachment #693352 - Flags: review?(jhammel)
...instead list #developers unless custom sheriff text specified for that tree in Config.js

This and patch part 2 were the last consumers of the calendar code (and thus the Google jsapi include).
Attachment #693353 - Flags: review?(jhammel)
Attachment #693354 - Flags: review?(jhammel)
Duplicate of this bug: 821363
Blocks: 764801
Blocks: 821363
Attachment #693348 - Flags: review?(jhammel) → review+
Comment on attachment 693349 [details] [diff] [review]
Part 2: Don't embed buildduty calendar, just link to it

seems a lot safer
Attachment #693349 - Flags: review?(jhammel) → review+
(In reply to Ed Morley [UTC+0; email:edmorley@moco] from comment #3)
> Created attachment 693352 [details] [diff] [review]
> Part 3: Move where we generate the custom sheriff text
> 
> We have no need to generate it in the same block that sets the tree
> open/closed/approval required status; no idea why it was put there.

Probably convenience at the time ;)
Attachment #693352 - Flags: review?(jhammel) → review+
Comment on attachment 693353 [details] [diff] [review]
Part 4: Stop using defunct sheriff calendar

again, seems a lot safer :) I love code removal
Attachment #693353 - Flags: review?(jhammel) → review+
Comment on attachment 693354 [details] [diff] [review]
Part 5: Specify custom sheriff for more trees

lgtm
Attachment #693354 - Flags: review?(jhammel) → review+
Depends on: 823926
In production.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
No longer blocks: 821363
Duplicate of this bug: 821363
Product: Webtools → Tree Management
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.