Images not displayed on reload

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
18 years ago
16 years ago

People

(Reporter: christinehoff4, Assigned: pavlov)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Tested on the following builds:

Win: 05_22_06_trunk
Mac: 05_22_10_trunk
Linux: 5_22_08_trunk

Open the attached file. There are three images on the right side - a downward 
caret, an upward caret and an 'x'. These are external images. Reload the page 
several times. The browser does not consistently reload the images. I don't know 
if this is a cache problem but I will start there.
(Reporter)

Comment 1

18 years ago
Created attachment 35707 [details]
Document to demonstrate problem
(Reporter)

Updated

18 years ago

Comment 2

18 years ago
Pav, I went to this page, cleared my caches and pressed reload several times. 
The images are in the HTTP disk cache and their fetch count increases, but the
images are not always in ImgLib's memory cache.

Could this be related to bug 82244?  We're fetching images more often than in the
5/18 build.
Assignee: gordon → pavlov
Component: Networking: Cache → ImageLib

Comment 3

18 years ago
I think this caching problem is affecting stylesheets, too. lots of JS in the
stylesheets get lost and causes problem like bug 82079.
This must be fixed before next beta.
Severity: normal → critical
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.3

Comment 4

17 years ago
WFM in a 7/22 branch build.  Can anyone verify?
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Reporter)

Comment 5

17 years ago
Using 7/27 build, WFM as well. Marking verified.
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
I'm having a similar problem with images failing to load on a page reload. I'm
using Windows BuildID: 2002041711, (1.0 RC1). In my case, I know what the
problem is, (which may not be the same as the original issue described in this
bug). I am seeing images fail to reload every second time I reload the page,
(first reload fails, second succeeds and so on).

What is happening is that the browser is not supplying the correct referring
page information to the server on the reload. I can tell this because my
webserver's error log shows a "client denied by server configuration" error
message for each of the images that fails to load.

Here are the lines from my, (apache), httpd.conf that block external use of images:

SetEnvIfNoCase Referer "^http://www\.jfitz\.com/" local_ref=1
<FilesMatch "\.(gif|jpg|png)">
    Order Allow,Deny
    Allow from env=local_ref
</FilesMatch>

As you can see, I require the browser to supply a referring page beginning with
"http://www.jfitz.com/". With this restriction, I can toggle images on/off on
any page on my site by hitting the reload button.

Comment 7

17 years ago
Full version details: Mozilla 1.0 Release Candidate 3 - Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.0rc3) Gecko/20020523

The problem described in note#6 is still present in RC3. I am re-opening this bug.

BTW: I no longer have the referring page rule in my own httpd.conf so this bug
cannot be tested against my site. I temporarily re-enabled the rule to verify
that the bug is still present in RC3.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

16 years ago
Should we change the Target Milestone to some real value, since 0.9.4 was
released looong-looong ago?

Comment 9

16 years ago
Reseting old target. Stuart, please set any more relevant.
Keywords: testcase
Target Milestone: mozilla0.9.4 → ---
(Assignee)

Updated

16 years ago
Blocks: 158715

Comment 10

16 years ago
I can not reproduce this with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021205

I know something went in around the time of mozilla 1.2.1 that
changed things with image and how things are cached/requested.
However even with 1.0 I can't reproduce it.

Can you still recreate this?
If so, what is your Edit->Preferences->Advanced->Cache "Compare the page..."
set at?  EveryTime, OutofDate, Once, Never

Comment 11

16 years ago
I can't recreate this bug using mozilla 1.3a.  Can you retry
with 1.3a (or newer) and if you are still seeing the problem
please reopen and indicate what your "cache preference" is
set to.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.