Switching ringtones is non-intuitive

RESOLVED DUPLICATE of bug 1033859

Status

RESOLVED DUPLICATE of bug 1033859
6 years ago
4 years ago

People

(Reporter: jaws, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When switching ringtones, the user needs to hit the "Done" button in the top right of the page, but for over a week I was hitting the Back button because I never noticed the Done button.

Some settings pages have a Done button but some don't. This lack of consistency can be confusing and caused me to think that my ringtone changes weren't being saved and that there was a different bug at hand (bug 820277).
Created attachment 694187 [details]
Select "Screen Timeout" has "OK" button in Display page.

Agree with Jared.
Or we can try to popup a selection page which has "OK" and "Cancel" button, like the "Display" and "Date & Time" page.
Duplicate of this bug: 822604
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
See Also: → bug 796499

Updated

5 years ago
Component: Gaia::Dialer → Gaia::Settings

Updated

4 years ago
Component: Gaia::Settings → Gaia::Ringtones

Comment 3

4 years ago
Maybe instead of a "back" button, we should use an "X" button to indicate that hitting it means "cancel"?

I think being able to cancel out of the activity is useful if you change your mind (e.g. you've tried a few different ringtones and lost the original selection, but you realized you don't want to change your ringtone after all).

Comment 4

4 years ago
Duping forward since the other bug has a clearer description.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033859
You need to log in before you can comment on or make changes to this bug.