Social Sharing Widget obscures Facebook flyout

VERIFIED FIXED

Status

Websites
Other
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: cmore, Assigned: craigcook)

Tracking

Details

(Whiteboard: r=111748)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 693587 [details]
Flyout issue

Facebook how includes fly outs by default on their "Like" button. This flyout is being obscured the drop down box in the social sharing widget.

Facebook is aware and their bug is here:

https://developers.facebook.com/bugs/273187646125577

Updated

5 years ago
Duplicate of this bug: 823992
(Assignee)

Updated

5 years ago
Assignee: nobody → craigcook.bugz
(Assignee)

Comment 2

5 years ago
Part of the CSS reset was applying max-width: 100% to all iframe elements to prevent inline frames from breaking layout, which is normally good to have. The Facebook dialog is in iframe in a positioned container that's meant to overlay other content, but the dialog's positioned container lacks a width so the iframe was getting its width from the dropdown, hence only as wide as the menu and didn't overflow as Facebook intended.

This is fixed in r111748. I've removed the global max-width for iframe elements and instead applied it only to iframes in a post body (still to prevent layout breakage for other embedded frames that we use in blog posts, like Github gists or jsfiddle).

We'll get this pushed to prod ASAP.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: r=111748
(Assignee)

Comment 3

5 years ago
The fix is in production.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.