Redirect mozilla.org/telemetry to wiki.mozilla.org/Telemetry/FAQ

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: lmandel, Assigned: pmac)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=dev c=redirect p=)

Attachments

(1 attachment)

In bug 821948 I identified that B2G includes an invalid URL http://www.mozilla.org/telemetry that is referenced for information about Telemetry. Jishnu Menon (legal) has directed the B2G team to point to our published Telemetry FAQ at http://wiki.mozilla.org/Telemetry/faq for v1.

While this faq is suitable for v1, we will likely want to publish a version of the faq that is mobile friendly for future releases. For this reason, I would like us to use a stable URL in B2G that can be redirected as required. telemetry.mozilla.org is already used as the entry point for the Telemetry dashboard. I would like to suggest that we use the URL that is already included in B2G (http://mozilla.org/telemetry) as the stable URL. I am also fine with using something like telemetry.mozilla.org/faq if that is possible and preferred.

Updated

6 years ago
Whiteboard: u=dev c=redirect p=
(In reply to Lawrence Mandel [:lmandel] from comment #0)
> Jishnu Menon (legal) has directed the B2G team to point to our
> published Telemetry FAQ at http://wiki.mozilla.org/Telemetry/faq for v1.

nit: Why is this "Telemetry/faq", instead of "/FAQ"? ("FAQ" is an acronym, so it's usually capitalized) Note that this isn't just a URL-prettiness thing -- the our wiki software displays the wiki-path (including the lower-case "faq") at the top of the page itself, in large print.

We can easily rename the existing page to the capitalized "FAQ" version of the page, but I don't want to step on anyone's toes or move this out from under an about-to-be-setup redirect...

(Note that there isn't any content at the capitalized location currently -- https://wiki.mozilla.org/Telemetry/FAQ says "There is currently no text in this page")
Hi,

could we go forward on this ?

In Bug 821948 comment 10 I suggested a durable URL for Telemetry informations for B2G that would be http://mozilla.org/firefoxos/telemetry (as we already have content at http://mozilla.org/telemetry).

We are now in the final straight for FFOS release ;)

Thanks !
Flags: needinfo?(lmandel)
Sorry, we don't have content at http://mozilla.org/telemetry, I don't know why I said that.

Anyway, I suggested an URL that would be specific to FFOS.
(In reply to Daniel Holbert [:dholbert] from comment #1)
> nit: Why is this "Telemetry/faq", instead of "/FAQ"? ("FAQ" is an acronym,
> so it's usually capitalized) Note that this isn't just a URL-prettiness
> thing -- the our wiki software displays the wiki-path (including the
> lower-case "faq") at the top of the page itself, in large print.

This is a good point. I have moved the page content to Telemetry/FAQ and added a redirect from Telemetry/faq to the new page.

(In reply to Julien Wajsberg [:julienw] from comment #2)
> In Bug 821948 comment 10 I suggested a durable URL for Telemetry
> informations for B2G that would be http://mozilla.org/firefoxos/telemetry

I don't see the need for a B2G specific Telemetry page but am fine proceeding with either URL at this point. I do think that a general Telemetry page that provides an overview of the system (currently provided by the FAQ) will be useful by desktop and mobile as well as B2G.
Flags: needinfo?(lmandel)
Lawrence> ok, fine for me ! Let's do that !

Therefore http://www.mozilla.org/telemetry should redirect to http://wiki.mozilla.org/Telemetry/FAQ

Who should this be assigned to ?
Chris - Can you take this one?
This kind of redirect is handled by Webdev usually.
CCing another Chris :)

Comment 8

6 years ago
(In reply to Lawrence Mandel [:lmandel] from comment #6)
> Chris - Can you take this one?

We have this tagged for an upcoming sprint session. Is this needed by a specific date?
The sooner the better but it can still wait a little as soon as we know it will be done soon :)

We were really in need of the final URL and we have it so that's good.

Comment 10

6 years ago
pmac: Here is a quick one that can be done since we don't have our sprint planning session until next Thursday. Thanks!
Assignee: nobody → pmac
PR submitted: https://github.com/mozilla/bedrock/pull/566
Status: NEW → ASSIGNED
Created attachment 699096 [details]
Pull request 566

Can we get a review soon in order to be able to close related gaia bug asap?
Attachment #699096 - Flags: review?(mkelly)
We also need to open a related bug to get the /b/ redirect done.
Comment on attachment 699096 [details]
Pull request 566

r+'d on github with one tiny change
Attachment #699096 - Flags: review?(mkelly) → review+
(In reply to [github robot] from comment #15)
> Commit pushed to master at https://github.com/mozilla/bedrock
> 
> https://github.com/mozilla/bedrock/commit/
> a1ab17ac13e2ac5e4d3b0779317dcbf0071c7038
> Bug 822817: redirect /telemetry

When will this be pushed to stage? I just checked and it is not there yet
[updating summary to indicate s/faq/FAQ/ per comment 4. Looks like the commit in comment 15 used the capitalized "FAQ", too; good.]
Summary: Redirect mozilla.org/telemetry to wiki.mozilla.org/Telemetry/faq → Redirect mozilla.org/telemetry to wiki.mozilla.org/Telemetry/FAQ
(In reply to raymond [:retornam] from comment #16)
> When will this be pushed to stage? I just checked and it is not there yet

It's on stage and prod actually, but it's still behind the /b/ url. Adding the redirect for that now.
Redirect pushed to prod and confirmed working.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.