Installing a hosted app, changing the app manifest data, then doing a manual sync - no app update notification fired

REOPENED
Unassigned

Status

Firefox OS
Gaia::System
REOPENED
5 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+)

Details

(Whiteboard: [UX-P?])

(Reporter)

Description

5 years ago
Build: B2G18 12/18/2012
Device: Unagi

Steps:

1. Install a hosted app from testmanifest.com with default manifest:

{
  "name":"Test App ({subdomain})",
  "description":"This app has been automatically generated by testmanifest.com",
  "version":"1.0",
  "icons":{
    "16":"http://testmanifest.com/icon-16.png",
    "48":"http://testmanifest.com/icon-48.png",
    "128":"http://testmanifest.com/icon-128.png"
  },
  "installs_allowed_from":[
    "*"
  ],
  "developer":{
    "name":"Gregory Koberger",
    "url":"http://gkoberger.net"
  }
}

2. On testmanifest.com, modify the manifest to not include an icon:

{
  "name":"Test App ({subdomain})",
  "description":"This app has been automatically generated by testmanifest.com",
  "version":"1.0",
  "installs_allowed_from":[
    "*"
  ],
  "developer":{
    "name":"Gregory Koberger",
    "url":"http://gkoberger.net"
  }
}

3. Go to settings --> device info --> check for updates

Expected:

A notification should fire saying that there is an app update, as the app manifest for an installed host app has changed.

Actual:

No notification for update fires.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
(Reporter)

Comment 1

5 years ago
Note - if you restart the phone, then the update is successfully applied on the app. But I never got a notification in the first place about the update.
(Reporter)

Comment 2

5 years ago
A followup note - the update isn't applied until after you restart the phone too. There's probably two bugs here which I'll split out - no notification for the update and silent application of the update without user consent.
(Reporter)

Comment 3

5 years ago
Broke out bug 822862 about lack of user consent. let's use this bug for the no update notification.
(Reporter)

Updated

5 years ago
Summary: Installing a hosted app with an icon, then changing the manifest to have no icon, then doing a manual sync - no app update notification fired → Installing a hosted app, changing the app manifest data, then doing a manual sync - no app update notification fired
Component: Gaia::System → General

Updated

5 years ago
Flags: needinfo?(fabrice)
Flags: needinfo?(fabrice)
I think this is a dupe of bug 823040.
Flags: needinfo?(fabrice)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823040
Bug 823040 is specifically about updating hosted apps with appcache, and this could fix this bug in this case (although there may be gaia work).

This bug is about hosted apps in general, and to my knowledge gecko doesn't send a notification to gaia for hosted apps without appcache (as you saw in Bug 822862). How would you want the Homescreen to apply the changes anyway without a notification ?

Reopening this bug, but I think this should not be blocking, as the app is correctly updated, only the icon change is not applied.

Jason, if you find there is a problem with permissions change, then there is a bigger bug, but I think that would work.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I'm wrong about the notification part for hosted apps without appcache, we get a downloadapplied event anyway.

If I understand correctly, Jason, you'd like a notification that the app was updated ? I don't think we want this: this is the web, the apps get updated anyway, that's normal. I was told that we don't want notifications for things that we can't act upon.

So I'm recommending closing this bug as invalid and keeping Bug 822870 for the changes in Homescreen.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 822870
(Reporter)

Comment 9

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #7)
> I'm wrong about the notification part for hosted apps without appcache, we
> get a downloadapplied event anyway.
> 
> If I understand correctly, Jason, you'd like a notification that the app was
> updated ? I don't think we want this: this is the web, the apps get updated
> anyway, that's normal. I was told that we don't want notifications for
> things that we can't act upon.

I don't agree. You are basically updating an app on the device without even telling the user that the update happened. So exactly how are they supposed to know that they may need to act upon something as a result of the update? For example, the perms might have changed. The web activities may have changed. Etc. No knowledge of knowing that basically removes any knowledge to the user that they could do something as a result of an update.

> 
> So I'm recommending closing this bug as invalid and keeping Bug 822870 for
> the changes in Homescreen.

This has nothing to do with bug 822870. It's about an update notification getting fired. I'm sending over to UX.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

5 years ago
Flags: needinfo?(jcarpenter)
(Reporter)

Comment 10

5 years ago
Note that as I stated in the other bug, I agree with Fabrice that silent application of the update was okay as long as UX is okay with it. But I still think you should be giving knowledge that the update actually happened.
(Reporter)

Comment 11

5 years ago
This is also a gaia issue, not a gecko issue.
Component: General → Gaia::System
(Reporter)

Updated

5 years ago
Blocks: 823525
Triage: since the update does successfully get applied, we are marking blocking- and tracking+ for now. Josh, please re-nom if you feel this is a v1 must have.
blocking-basecamp: ? → -
tracking-b2g18: --- → +
(Reporter)

Updated

5 years ago
No longer blocks: 823525
(Reporter)

Updated

5 years ago
Whiteboard: [UX-P?]
I share Jason's concern that we're updating user's apps without telling them in advance. That's been a long standing concern with the implementation of appcache-less hosted apps in v1. We empower the user to provide informed consent for _some_ app updates, but keep them in the dark about others, unable to intervene and presumably ignorant that anything has happened in the background. Even though expensive bandwidth may have been consumed.

Two questions:

* Can we estimate how often appcache-less hosted apps will need to update? Only when the dev alters the manifest? 
* Do appcache-less hosted apps have to restart before the updates are applied?
* Can someone give an LOE estimate for adding a "[AppName] has been updated" banner when these updates have been applied?
Flags: needinfo?(jcarpenter)
Josh> there will be no expensive consumed bandwidth for hosted apps without appcache. I think that's why we're just updating them without a notice. You always get the most recent version of the site/application. That's the web, man !

Plus, the app can be updated without a manifest change... so what ? That's the web, man !

Now, the questions :
* we need to change gecko database and the homescreen icon when the dev changes the manifest. However, the app might be changed anyway. The only case I'm concerned about is if the permissions are changed: then what happens ? (I don't know if hosted apps can have permissions, indeed).
* yes like a normal web site. But we might not be informed.
* Adding the banner should be really easy, I think we already have everything we need in System's update_manager.js. But let's think first.

I agree that a name change could be useful to know. However, a small banner won't be sufficient because there is a high probability that the smartphone will be in the pocket when that happens anyway. We'd at least need a persistent notification.

I agree as well that a permission change (if this is permitted (?)) should be agreed too.
You need to log in before you can comment on or make changes to this bug.