Cached Jar Files Never Reloaded

RESOLVED DUPLICATE of bug 100484

Status

Core Graveyard
Java: OJI
P3
normal
RESOLVED DUPLICATE of bug 100484
17 years ago
8 years ago

People

(Reporter: Corey.Jewett, Assigned: Joe Chou)

Tracking

Trunk
mozilla0.9.8
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'm developing a fairly large applet (~100K) which is subdivided into multiple
jars. Mozilla refuses to reload the new jar file. All jar overwritten.

Applet tag:

<applet alt="Your browser does not support Java." 
            code="com.threedef.XXXXXXXXX.XXXXXXXXXXX.class" 
            archive="/html/session/graphics/XXXXXXapplet.jar,
/html/session/graphics/awt.jar, /html/session/graphics/XXXXXXXXXXXX.jar"
width=635 height=334>
// Bunch of params
</applet>

I have progressively worked up the cache settings from "Once per session" to
"Every time..." I have also set Memory and Disk caches to zero. Clearing the
caches makes no difference. Both reload and SHIFT+Reload don't refresh it. (I'm
using the reload in the contextual popup, not the menu bar since the applet is
in a menubar less window.)

The only way I've found to clear the jar files is to completely exit the
browser. It may be necessary to clear the caches first, but I'm not entirely sure.

Netscape 4.76 does the cache comparison correctly.

OS: RedHat 7.0.

Thanks for the awesome browser.
(Reporter)

Comment 1

17 years ago
Follow-up.

Noticed the "x: clear classloader cache" key command in the Java Console. This
appears to have cleared the cache, but now the main applet class is no longer
being found. I verified that it is in the jar file.

Also thought it might be relevant to know that I'm pulling the jars and html
page down from a web server.

Comment 2

17 years ago
Well, this doesn't sound like it has anything to do with the networking cache.

Gagan, could this be OJI?  Who should look at this next?
Assignee: gordon → gagan
Component: Networking: Cache → OJI

Comment 3

17 years ago
maybe OJI owner then?
Assignee: gagan → edburns
QA Contact: tever → shrir

Comment 4

17 years ago
After you use the x feature in the java console, go to a non-java html page, 
then re-visit your applet page.  Does that work?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

17 years ago
p3 normal
Severity: major → normal
Priority: -- → P3

Comment 6

17 years ago
This may be what you're looking for to handle your jar caching for you.  Try 
this:



<applet alt="Your browser does not support Java." 
        code="com.threedef.XXXXXXXXX.XXXXXXXXXXX.class" 
        width=635 
        height=334>

<PARAM NAME='cache_option' 
       VALUE='Plugin'>

<PARAM NAME='cache_archive' 
       VALUE='/html/session/graphics/XXXXXXapplet.jar,
             /html/session/graphics/awt.jar, 
             /html/session/graphics/XXXXXXXXXXXX.jar>

<PARAM NAME='cache_version'
       VALUE='a.b.c.d,a.b.c.d,a.b.c.d'>

// Bunch of params
</applet>

Using the PARAM tags tell the JRE to load the a.b.c.d version of each jar file 
only once.  The only time it will download the jar files a second time is if 
you change the filename or change the associated version (in hexidecimal) for 
that jar file in the cache_version tag.

Read up on the cache_option, cache_archive, cache_version PARAMs at:

http://java.sun.com/products/plugin/1.3/docs/appletcaching.html

for more detailed info.

Comment 7

17 years ago
SPAM: reassigning all OJI bugs to new OJI QA, pmac ( 227 bugs)
QA Contact: shrir → pmac

Comment 8

17 years ago
Ressign to Joe Chou, as I am no longer working officially on OJI.
Assignee: edburns → joe.chou
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla0.9.6

Comment 9

17 years ago
I think this is the dup of 100484. Java Plugin doesn't load updated
*jar files it loads them from cache. There is the RFE #4523418 in bugtraq
with synopsis: java plugin doesn't reload updated applets. The same situation
is with the updated jars. The existing version of java plugin
doesn't have the opportunity to be informed that applet (or jars)
should NOT be taken from the cache. The only way now is to use
option 'x' in java console. I propose to close
this bug as dup of 100484
(Assignee)

Comment 10

17 years ago
Re-assign to laa.
Assignee: joe.chou → laa
Target Milestone: mozilla0.9.6 → mozilla0.9.8

Comment 11

17 years ago
Will mark it as duplicate of 100484 in two days if no objections.

Comment 12

17 years ago

*** This bug has been marked as a duplicate of 100484 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 13

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: laa → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.