[Settings] App Permissions UI does not list non-certified preinstalled apps

RESOLVED DUPLICATE of bug 821961

Status

RESOLVED DUPLICATE of bug 821961
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+)

Details

(Reporter)

Description

6 years ago
Currently, the app permissions UI does not list any app that's preloaded on device that's non-certified. For example, the maps app is currently not shown on this UI at all, even though technically it's classified as a hosted app preloaded on device. We should be listing preloaded apps in this UI that are non-certified and allow users to control the permissions on those apps.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
(Reporter)

Updated

6 years ago
Blocks: 815411
Summary: [Settings] App Permissions UI does not list non-certified preloaded apps → [Settings] App Permissions UI does not list non-certified preinstalled apps
Would take a patch for that.
blocking-basecamp: ? → -
tracking-b2g18: --- → +
(Reporter)

Comment 2

6 years ago
(In reply to David Scravaglieri [:scravag] from comment #1)
> Would take a patch for that.

I don't know if we can go out the door without this. We're basically shooting partner apps in the foot here. Why would I want to be a top app preinstalled on device if I get an inferior experience?
blocking-basecamp: - → ?
(Reporter)

Updated

6 years ago
tracking-b2g18: + → ---
We would take a patch on this of course...
blocking-basecamp: ? → -
tracking-b2g18: --- → +
(Reporter)

Comment 4

6 years ago
I believe this was fixed by bug 821961.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 821961
(Reporter)

Updated

6 years ago
No longer blocks: 815411
You need to log in before you can comment on or make changes to this bug.