[CONTACTS][FACEBOOK] Company name is not updated in contacts list until you enter in contact details

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: carlosmartinez, Assigned: crdlc)

Tracking

unspecified
x86_64
Windows 7

Firefox Tracking Flags

(blocking-basecamp:-)

Details

Attachments

(1 attachment)

Tested with:

Gecko-cb6ee76
Gaia-16006ea

STR:
1-Import facebook contacts
2-Create a contact and link it to a facebook contact which has its current company filled
3-Go to facebook and change the company of this contact
4-Update facebook friends info
5-Go to contacts list

Expected result --> The name of the company of the contact you have created is the current one (you have just change it) both in the list of contacts and in the details of the contact

Actual result --> The name of the company is not updated in contacts list until you go to the details of the contact and come back
Same thing is happening when changing the name, and maybe with the rest of the fields too.
(Assignee)

Updated

6 years ago
Assignee: nobody → crdlc

Comment 2

6 years ago
this should be fixed yes or yes.
Status: NEW → ASSIGNED
blocking-basecamp: --- → ?
(Assignee)

Comment 3

6 years ago
Created attachment 693838 [details]
Patch v1
Attachment #693838 - Flags: review?(jmcf)

Updated

6 years ago
Attachment #693838 - Flags: review?(jmcf) → review+
Request vingtetun approval please
blocking-basecamp: ? → -
(Assignee)

Comment 5

6 years ago
Comment on attachment 693838 [details]
Patch v1

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #693838 - Flags: approval-gaia-master?(21)
(Assignee)

Comment 6

6 years ago
no risk Vivien

Updated

6 years ago
Duplicate of this bug: 823430
Attachment #693838 - Flags: approval-gaia-master?(21) → approval-gaia-master+
(Assignee)

Comment 8

6 years ago
https://github.com/mozilla-b2g/gaia/commit/487694dc29cc0e69cc804ae2a10fd4e03def731b
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 9

6 years ago
The bug is not resolved, I have reproduced the bug in version:
Gecko-cfad7c9
Gaia-6c53dfd

1-Import facebook contacts
2-Go to facebook and change the company of this imported contact
4-Update facebook friends info
5-Go to contacts list

Expected result --> The name of the company is updated

Actual result --> The name of the company is not updated in contacts list until you go to the details of the contact and come back
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

6 years ago
I can reproduce this problem if the device and Facebook service have different time. We update the friends when the update time for a friend provided by Facebook is bigger than last update in the device. Please check the time in your device and follow these steps: 

Go to import card in your device
Wait 5 minutes
Change the company in Facebook
Go to import card in your device
Go to contact list and probably the info would be updated
(Assignee)

Comment 11

6 years ago
please test that
Flags: needinfo?(rafael.marquez)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Flags: needinfo?(rafael.marquez)
You need to log in before you can comment on or make changes to this bug.