If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

History window should default to showing most recent folders first

RESOLVED WORKSFORME

Status

()

Core
History: Global
P3
minor
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: Blake Ross)

Tracking

({helpwanted, polish})

Trunk
Future
helpwanted, polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 2001052115, Mac OS 9.1

To reproduce:
*   Create a new Mozilla profile.
*   Open the History window.
*   Look at the topmost folder.

What you should see:
*   The `Today' folder.

What you actually see:
* The `Older than 6 days' (gerk!) folder.
(Reporter)

Updated

17 years ago
Keywords: polish

Comment 1

17 years ago
while I like this (and it's the sort direction I usually use), I can't remember
how to kick off a default sort, and you can sort by just clicking on "Name", and
it will persist..
Status: NEW → ASSIGNED
Keywords: helpwanted
Priority: -- → P3
Target Milestone: --- → Future

Comment 2

17 years ago
*** Bug 82574 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
Alec, the sort seems to persist in the history window, but not the sidebar tab.

Comment 4

17 years ago
hrmm.. it persists ok for me in both the sidebar and the history window, build
2001052404, Win 2000

Comment 5

17 years ago
Yeah, it doesn't work for me on the same build, Win 98.  Maybe I'm doing
something wrong.  Here's what I'm doing:

1) opening history management window
2) from view menu, changing sort from A>Z to Z>A

This changes the order of the heirarchy in the management window, but not the
sidebar.

Comment 6

17 years ago
oh! no, the sort is per-window - i.e. the history window has it's own sort,
independant of the sidebar sort...you can click on the column headers to
initiate the sort in the sidebar

Comment 7

17 years ago
Ah, of course.  Should have thought of that.  Cool, thanks!

Comment 8

16 years ago
argh.. take two at reassigning history bugs to new owner
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
Target Milestone: Future → ---
(Assignee)

Updated

16 years ago
Target Milestone: --- → Future

Comment 9

14 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Updated

14 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 10

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

View->Sidebar->History shows a list of folders with Today at the top.

resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.