Make the dev.tree-management Talos email subjects easier to scan

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: emorley, Assigned: emorley)

Tracking

({sheriffing-P1})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
I find the current subjects hard to scan quickly:

Talos Regression :( Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) increase 0.995% on Win7 Mozilla-Inbound

Talos Regression :( Trace Malloc Leaks increase 0.379% on MacOSX 10.7 Mozilla-Inbound

etc

We should:
* Put the tree name earlier in the string
* Use separators to more clearly break up the testname/platform/result
(Assignee)

Comment 1

6 years ago
Created attachment 693827 [details] [diff] [review]
Patch v1

(In reply to Ed Morley [UTC+0; email:edmorley@moco] from comment #0)
> Talos Regression :( Tp5 No Network Row Major MozAfterPaint (Main Startup
> File IO Bytes) increase 0.995% on Win7 Mozilla-Inbound

This becomes...

Talos Regression: Mozilla-Inbound - Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) - Win - 0.995%

Also adjusted the email body copy to match.
Assignee: nobody → edmorley.bz
Status: NEW → ASSIGNED
Attachment #693827 - Flags: review?(catlee)
Comment on attachment 693827 [details] [diff] [review]
Patch v1

Review of attachment 693827 [details] [diff] [review]:
-----------------------------------------------------------------

::: server/analysis/analyze_talos.py
@@ +579,2 @@
>          else:
> +            reason = "Regression"

tempted to r- just for this! :P

you don't like the emoticons?

@@ +581,5 @@
>  
>          if new_value > initial_value:
>              direction = "increase"
>          else:
>              direction = "decrease"

get rid of this block if you're not going to use 'direction'
Attachment #693827 - Flags: review?(catlee) → review+

Comment 3

6 years ago
While we're at it, I wouldn't mind taking out the Talos from the subject line since not all of the emails are Talos regressions.  I've had to explain several times in the last year that "Number of constructors" is not actually a Talos test (and then they would logically ask: "Then why does the email say Talos?")
(Assignee)

Comment 4

6 years ago
Agree about dropping talos. Also means less of the subject is potentially wrapped/pushed off-screen.

Taking into account the comment in bug 823008, how about (imagine one were skim reading):

<Regression> Mozilla-Inbound - Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) - Win - 0.995%
(Improvement) Mozilla-Inbound - Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) - Win - 0.995%
(Improvement) Mozilla-Inbound - Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) - Win - 0.995%
<Regression> Mozilla-Inbound - Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) - Win - 0.995%
<Regression> Mozilla-Inbound - Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) - Win - 0.995%

Re the emoticon, I like it, but it just didn't play nicely with the various separators I tried.
That works for me -- definite improvement over the existing format.

Comment 6

6 years ago
lgtm; personally i would put the % earlier, but not a strong opinion.  Hopefully going forward we can get these test names tamed a bit too (but that's a different issue entirely)
(Assignee)

Comment 7

6 years ago
Created attachment 694117 [details] [diff] [review]
Patch v2

(Patch as landed)

Thank you for the feedback :-) Regarding % earlier on in the string - with bug 822249 I hope that we'll have less irrelevant mail, so think it will be ok to favour grouping in a more logical manner vs seeing the % sooner. We can always adjust later on if it turns out to be annoying.

https://hg.mozilla.org/graphs/rev/7c9a79bc41d7
Attachment #693827 - Attachment is obsolete: true

Comment 8

6 years ago
To be fair, with datazilla in the pipeline we're going to have to change how this works across the board, so any improvements we do here are interim.
(Assignee)

Comment 9

6 years ago
(In reply to Jeff Hammel [:jhammel] from comment #8)
> To be fair, with datazilla in the pipeline we're going to have to change how
> this works across the board, so any improvements we do here are interim.

Agreed, but I imagine we'll be running in parallel for a bit, so the more tolerable the better :-)

catlee, how do we deploy the changes? :-)
(In reply to Ed Morley (Away 20th Dec-2nd Jan) [UTC+0; email:edmorley@moco] from comment #9)
> (In reply to Jeff Hammel [:jhammel] from comment #8)
> > To be fair, with datazilla in the pipeline we're going to have to change how
> > this works across the board, so any improvements we do here are interim.
> 
> Agreed, but I imagine we'll be running in parallel for a bit, so the more
> tolerable the better :-)
> 
> catlee, how do we deploy the changes? :-)

poke me tomorrow!
(Assignee)

Comment 11

6 years ago
In production
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering

Comment 12

3 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/b0436d0f3001b7f50a46dd5c9bb24baaf428cd2b
Bug 823016 - Make the dev.tree-management Talos email subjects easier to scan; r=catlee

Updated

3 years ago
QA Contact: mshal
You need to log in before you can comment on or make changes to this bug.