If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New tab does not open Chrome’s "New Tab" Page anymore, but throws error.

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Magnus, Unassigned)

Tracking

17 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Whenever I open a new tab at this Compter (Win7 Starter) this bub appears. To exclude problems with Pug-Ins, I started with disabled Plug-Ins, but the Error does not disappear.


Actual results:

A white new Tab opens.
The Error console first throws the message:
No chrome package registered for chrome://unitedtb/content/newtab/newtab-page.xhtml
Then it throws the Error:
Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIWebNavigation.loadURI]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml :: loadURIWithFlags :: line 156"  data: no]
Source File: chrome://browser/content/tabbrowser.xml
Line: 1361


Expected results:

A new Tab should open with 9 small frames for the 9 most visited pages or pages which are "pinned" there. I pinned a few pages there some versions of Firefox ago.

To my knowledge this New-Tab page is now part of a normal Firefox installation and I can not remember fiddling arround with this functionality. The feature still works at my other computers with Windows 7 Professional. I can not tell why it does not work (anymore) and have no idea how to fix it.
Please try it with Firefox:help/restart with addons disabled 

What happens if you enter about:newtab in Firefox as URL ?
(Reporter)

Comment 2

5 years ago
Hi Matti

As for the first point, I already did this (thats what I meant with "started with disabled Plug-Ins") and the result is the same as without disabled plugins.

When I enter "about:newtab" the usual window with the 9 fields appears.

Thanks. I found the reason for the error. A Plug-In to be found at:
https://produkte.web.de/mailcheck/logik/mailcheck-firefox

When installing this Plug-In, it replaces the new-tab by own new-tab which is just a web-search, 4 recommended site links and in the middle the usual 9 fields.
When disabling this Add-On, the New-Tab window then throws this error.
When removing this Add-On while it is disabled, this error is persistent. And that was my problem.
When removing this Add-On while it is not disabled, this error does not appear and the installing and removing procedure fill fix this problem. 

I can now reproduce the bug with the steps just mentioned:
Install this Plug-In, deactivate this Plug-In and de-install then this Plug-In.
Plugins are Flash, Java, quicktime.The name confusing is the reason why I wanted to be sure that you tried it with disabled extensions.

The extensions seems to change the option browser.newtab.url .
You can manually correct it via about:config , the default value is about:newtab

I guess that it does some cleanup if you deinstall it but this cleanup can not be performed if it's already disabled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.