Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 818507
6 years ago
6 years ago

People

(Reporter: bsilverberg, Assigned: gwagner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
On my b2g testdriver phone, build is 20121212102240, when I try to add a contact, and I click the "Done" button, the button changes colour, but the contact is not saved. It just remains at the "Add contact" screen.

Checking adb logcat I see:
E/GeckoConsole(  562): [JavaScript Error: "formats is undefined" {file: "resource://gre/modules/PhoneNumber.jsm" line: 78}]

Steps to Reproduce:
1. Open Contacts
2. Click "+" button
3. Enter a first name, last name and phone number (the format I used was 9999999999).
4. Click "Done"

Expect result: Contact is added.
Actual result: The Done button deactivates, but the screen remains on Add contact and the contact is not added.

Comment 1

6 years ago
seems to be a phonenumber.js issue
(Assignee)

Comment 2

6 years ago
That's most likely a dup of bug 818507.
It should be fixed with the next update.
(Assignee)

Updated

6 years ago
Assignee: nobody → anygregor
(Assignee)

Comment 3

6 years ago
Please reopen if it still happens after the next update.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818507
You need to log in before you can comment on or make changes to this bug.