Closed Bug 823040 Opened 7 years ago Closed 7 years ago

we should update the app's manifest during update (for hosted apps with appcache)

Categories

(Core Graveyard :: DOM: Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

RESOLVED FIXED
mozilla20
blocking-basecamp +
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: julienw, Assigned: fabrice)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

We update the manifest at 2 points : [1] and [2] 

In the hosted apps with appcache case, we're not executing these lines though. We should update the manifest somewhere in [3].

Nominating as this could impact our update mechanism and this is a very low-risk patch (one line).

[1] http://mxr.mozilla.org/mozilla-central/source/dom/apps/src/Webapps.js#524
[2] http://mxr.mozilla.org/mozilla-central/source/dom/apps/src/Webapps.js#529
[3] http://mxr.mozilla.org/mozilla-central/source/dom/apps/src/Webapps.js#472
Assignee: nobody → fabrice
blocking-basecamp: ? → +
Attached patch patchSplinter Review
We failed to update the app.manifest (or app.updateManifest for packaged apps) when checking for updates.
Attachment #694080 - Flags: review?(ferjmoreno)
Duplicate of this bug: 822855
Blocks: 822870
Attachment #694080 - Flags: review?(ferjmoreno) → review+
https://hg.mozilla.org/mozilla-central/rev/a2e79ebb34af
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Whiteboard: [qa-]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.