Last session is missing when closing Firefox with File > Exit from last private window

RESOLVED DUPLICATE of bug 819510

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 819510
5 years ago
3 years ago

People

(Reporter: tabmix.onemen, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Steps to reproduce:

1. Open non-private window with few tabs
2. set Firefox to "Show my windows and tabs from last time"
3. Open private window with tabs.
4. Close the non-private window. (the window is now in the closed window list).
5. Exit Firefox using File > exit.
6. Start Firefox.

Actual results:
Firefox start without the last session and History > restore previous session is disabled

After exiting Firefox in step 5. with close button on the top right or Alt+F4 or Ctrl+Shift+W, next start restore the session as expected.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819510

Updated

3 years ago
Summary: Lase session is missing when closing Firefox with File > Exit from last private window → Last session is missing when closing Firefox with File > Exit from last private window
You need to log in before you can comment on or make changes to this bug.