Links opened from e.me in browser fail to resize.

RESOLVED INVALID

Status

Firefox OS
Gaia::Everything.me
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: liuche, Assigned: ranbena)

Tracking

({b2g-testdriver, unagi})

Firefox Tracking Flags

(Not tracked)

Details

Both pinch-zoom and double tap for resizing fail to work on content pages (e.g. news articles) opened from an e.me app (in this case, the Facebook app).

STR:
1. Open Facebook e.me app.
2. Click a link to article.

Expected:
Double-tap to resize, or at least pinch-zoom works.

Actual:
Only scrolling around the content works. Makes reading articles really difficult.
Chenxia, can you supply a reproducable scenario? (one that doesn't involve logging in to a service)

Also, have you tried the same in Gaia Firefox?
Flags: needinfo?(liuche)
The problem with resizing/double-tap does not occur in Gaia Firefox.

Additional repro steps:
1. Go to e.me screen > News.
2. Open NYTimes app.
3. Double-click to resize article or pinch-zoom.

Expected:
Resizing occurs.

Actual:
Can't resize.

Observed on Nightly 20121219070201
Flags: needinfo?(liuche)
Vivien, who should this be assigned to?
(In reply to Chenxia Liu [:liuche] from comment #2)
> The problem with resizing/double-tap does not occur in Gaia Firefox.
> 
> Additional repro steps:
> 1. Go to e.me screen > News.
> 2. Open NYTimes app.
> 3. Double-click to resize article or pinch-zoom.
> 
> Expected:
> Resizing occurs.
> 
> Actual:
> Can't resize.
> 
> Observed on Nightly 20121219070201

This is expected. App frames are not suppose to be panable/zoomable, AFAIK.

(In reply to Chenxia Liu [:liuche] from comment #0)
> Both pinch-zoom and double tap for resizing fail to work on content pages
> (e.g. news articles) opened from an e.me app (in this case, the Facebook
> app).
> 
> STR:
> 1. Open Facebook e.me app.
> 2. Click a link to article.
> 
> Expected:
> Double-tap to resize, or at least pinch-zoom works.
> 
> Actual:
> Only scrolling around the content works. Makes reading articles really
> difficult.

A popup frame might be subject to discussion though. Not sure we should set |mozasyncpanzoom| on this frame or not.
Assignee: nobody → ran

Comment 5

5 years ago
Is this a duplicate of bug 876705 ?
Flags: needinfo?(liuche)
Guys, I'd like to resolve this ticket.
Basically, all E.me results (apart from web results) are set with mozasyncpanzoom - making them unpanable and unzoomable.

This is by design by instruction from the browser/homescreen teams.

If this is wrong, it should be discussed.
(In reply to Amir Nissim (Everything.me) from comment #5)
> Is this a duplicate of bug 876705 ?

I'm really not sure, because I'm not familiar with the code, or what's being called.

I can't verify whether this problem still occurs because my unagi phone no longer gets updates, and the e.me facebook app is not working.
Flags: needinfo?(liuche)
Vivien, as long as we use asyncpanzoom for webapps, opening a non mobile adjusted page from inside of them - will always result in zoom-pan being needed but disabled.

Is there a way around this? Any solution in the future?
Flags: needinfo?(21)
(In reply to Ran Ben Aharon (Everything.me) from comment #8)
> Vivien, as long as we use asyncpanzoom for webapps, opening a non mobile
> adjusted page from inside of them - will always result in zoom-pan being
> needed but disabled.
> 
> Is there a way around this? Any solution in the future?

We gonna turn on mozasyncpanzoom on for everything somewhere between now and 1.4.

As a result, all webpages/webapps will be scalable and zoomable by default, but they have control over that with the meta viewport tag. So basically, an app that use a meta viewport for the current window, will be able to disable asyncpanzoom, but if the user navigate away then the new web page will not disable asyncpanzoom (except if this web page use a viewport too).

Does it makes sense?
Flags: needinfo?(21)
That's perfect!

Comment 11

5 years ago
Following Vivien and Ran's correspondence, can we now close this bug?
Flags: needinfo?(liuche)
This bug depends on Bug 909877. So, it should be tested again once the dependency is closed.
Depends on: 909877
Flags: needinfo?(liuche)

Updated

5 years ago
Blocks: 942267
Vikram

Please check if this is needed for 1.3 CS.
Flags: needinfo?(mvikram)

Comment 14

5 years ago
Now that APZC is enabled, can we verify this and close it out?
Flags: needinfo?(mvikram)
Flagging for QA to see if this is resolved by APZC.
Keywords: qawanted

Updated

5 years ago
QA Contact: dwatson

Comment 16

5 years ago
I am able to pinch-to-zoom in links clicked on from the "Facebook" e.me app. In the "New York Times" e.me app I was unable to pinch-to-zoom.

While being in the apps themselves I was unable to pinch-to-zoom.

Environmental Variables
Device: Buri 1.3 MOZ
Build ID: 20140121004137
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/6f7dfe36ab6c
Gaia: 47049555282a9a01fb60d1e1421b57e2810c96f5
Platform Version: 28.0a2
Firmware Version: v1.2-device.cfg

If this does not resolve the qawanted, please re-add keyword.
Keywords: qawanted
Ran

There seems to be a bug with facebook on e.me.

Can you please look into it?
Flags: needinfo?(ran)
Darren, can you please confirm that these apps are indeed zoomable in the browser?

From what I can tell, both Facebook and NY times are not zoomable when opened in the browser app. Opening in the E.me app is expected to work the same way.
Flags: needinfo?(ran) → needinfo?(dwatson)

Comment 19

5 years ago
"m.facebook.com": I was unable to pinch-to-zoom in the browser app, but when I tap on a link to go elsewhere I was able to pinch-to-zoom.(link clicked on kotaku.com)

"http://mobile.nytimes.com/": I was unable to pinch-to-zoom in the browser app.

My only issue is that I don't know if the m.facebook.com and New York Times are actually set up to accept pinch-to-zoom on their mobile site.
Flags: needinfo?(dwatson)
So, this is working per design. Can this bug be closed?
(In reply to Preeti Raghunath(:Preeti) from comment #20)
> So, this is working per design. Can this bug be closed?

Yes.
No longer blocks: 942267
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 909877
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.