[Video] There is no option available to allow the user to share video files through email, bluetooth and social networks.

RESOLVED DUPLICATE of bug 838008

Status

RESOLVED DUPLICATE of bug 838008
6 years ago
5 years ago

People

(Reporter: cschmoeckel, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: inarirun1, leorun1)

(Reporter)

Description

6 years ago
Summary: There is no UI option in the Video Player and File Browser that allows the user to share videos via email. There also is no option to add videos as attachment through the device's email app. 

Steps: 1. Open the Video App (with atleast 1 video available)
2. Select the Video
3. Tap the screen to view options

Result: There is no UI option available to the user allowing them to share the video via email. 

Expected Result: A share button is added to the Video App to allow users to share videos via email.

Build: 20121217070202 
This issue fails test case #1804 - Verify sharing a video via email
(Reporter)

Updated

6 years ago
Summary: [Video] There is no option available to allow the user to share video files through email. → [Video] There is no option available to allow the user to share video files through email and social networks.
(Reporter)

Comment 1

6 years ago
Additionaly there is no prompt or option for the user to share video files through various social networks. 
This fails test case #1806 - Verify sharing a video via social networks
(Reporter)

Comment 2

6 years ago
Test Run 2
This issue remains open on Unagi in Build 20130104070203
UCID misc-000
Testcase found here https://moztrap.mozilla.org/results/case/61080/
Whiteboard: testrun 2

Comment 4

6 years ago
Yes, I can reproduce it on "Unagi" build ID:20130115070201, Kernel Dec 5

Updated

6 years ago
Hardware: x86_64 → ARM

Updated

6 years ago
OS: Windows 7 → Gonk (Firefox OS)
(Reporter)

Comment 5

6 years ago
This Issue remains open, there is no option to share Videos in the Video Player app. 
Build ID: 20130125070201
Kernel: Dec 5
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18/rev/94a2d6fcdfde
Gaia:   6369dbf33b622faf4b4d176fed30b77c5c319dfc
(Reporter)

Updated

6 years ago
Whiteboard: testrun 2 → testrun 2, testrun 3
(Reporter)

Comment 6

6 years ago
Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9
Whiteboard: testrun 2, testrun 3 → testrun 2, testrun 4

Comment 7

6 years ago
This Issue remains open, there is no option to share Videos in the Video Player app.

Unagi Build ID: 20130225070200
Kernel: Dec 5
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3a5a27992a75
Gaia: 5691a16fff8e1403c75ed9d6f3a443b7e58198c6
UCID: misc-000
Test case id: https://moztrap.mozilla.org/runtests/run/859/env/305/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=1804
Whiteboard: testrun 2, testrun 4 → testrun 2, testrun 4, testrun 5.1

Updated

6 years ago
Whiteboard: testrun 2, testrun 4, testrun 5.1 → testrun 5.1
Need requirements check
Keywords: qawanted
(Reporter)

Comment 10

6 years ago
Adding Bluetooth to this bug as there is no option to share using any of these three methods in the Video App. 
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/e2d297ddf01d
Gaia: baec473de45d4971b86a470b7580cd1444585a26
Summary: [Video] There is no option available to allow the user to share video files through email and social networks. → [Video] There is no option available to allow the user to share video files through email, bluetooth and social networks.

Comment 11

6 years ago
Environmental  Variables:
Inari Build ID: 20130416070200
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6bac24e14538
Gaia: c883af5ecd0998f78d9aaa4c2337c842e1dbb5a0

Same issue reproduces with "Inari" device

UCID: misc-000
Test case id: https://moztrap.mozilla.org/runtests/run/859/env/305/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=1804
Whiteboard: testrun 5.1 → inarirun1

Updated

6 years ago
Whiteboard: inarirun1 → inarirun1, leorun1
There is now a share button in the video app.  I'm not sure when it was added, but I'm closing this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 13

6 years ago
Verified works for me as this button now appears in the Video App
Status: RESOLVED → VERIFIED
Keywords: qawanted
Resolution: FIXED → WORKSFORME

Updated

6 years ago
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 14

6 years ago
This bug still reproduces for me, the only video sharing option is Bluetooth, there is no email or social network video sharing.

Environmental  Variables:
Inari Build ID: 20130515070208
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f
For V1 train, I believe the test case is incorrect - according to the user scenarios for 1.1 this is what it says:

"As a user, from the Video application, I want to be able to send video files to another mobile device or computer using Bluetooth to make it easier to share content."

I can confirm using the latest V1 train build that the share button is there for Bluetooth. So we need to update the test case as it pertains to 1.1.

I can check the requirements for 1.0.1, but I imagine that feature is not present in that version so if there is a test case pertaining to 1.0.1 it should be disabled. I will report back when I find out that information.
Flags: in-moztrap?(mozillamarcia.knous)
(Reporter)

Comment 16

6 years ago
Disabled TCs 1804 (Verify sharing a video via email) and 1806 (Verify sharing a video via social networks) since the current UCIDs only mention sharing videos through BlueTooth. 
Versions 1.0, 1.0.1 and 1.1.0 were updated.

Comment 17

5 years ago
Created a test case covering transferring a video file through Bluetooth.

https://moztrap.mozilla.org/manage/cases/?filter-id=9255
Flags: in-moztrap?(mozillamarcia.knous) → in-moztrap+
Video can share to email since bug 838008 landed.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 838008
You need to log in before you can comment on or make changes to this bug.