Synaptic Touchpad drivers 16.x cause window borders to focus/unfocus constantly on scrolling, causing visible flickering and high CPU usage.

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

({regression})

20 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 694193 [details]
about support.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121219 Firefox/20.0
Build ID: 20121219030847

Steps to reproduce:

1. Start a new profile
2. Install the Gecko SPS profiler from  here https://github.com/bgirard/Gecko-Profiler-Addon/blob/master/geckoprofiler_amo.xpi   or https://addons.mozilla.org/en-us/firefox/addon/gecko-profiler/

3. Install the profiler. Enable it.
4. Click on the profiler icon. A pop up window opens with the green colored FPS/latency ticker.
5. Keeping mouse pointer inside theis window, scroll using the mouse wheel.


Actual results:

The Titlebar and the window margins visibly flickers.


Expected results:

no flickering.
*************************
Using the same version of profiler(1.9.8), this bug was not occuring earlier.  So this is related to Firefox code, rather than the profiler code.
(Reporter)

Updated

5 years ago
Keywords: regression
WFM over here Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121220 Firefox/20.0 ID:20121220030912 + Profiler 1.11.2.

There's no Scrollbar in that Release anymore.
(Reporter)

Comment 3

5 years ago
Scrolling is done by mouse wheel/scroll pad, when the mouse pointer is inside the popup window. 
The URL shows a screenr of the bug.

This has started occuring 3-4 days back only.


FWIW, I tried the same STR on another windows7 PC but couldnt reproduce on that.
(Reporter)

Comment 4

5 years ago
I can also repro this by the menu that appears on double clicking the "star button in address bar".

So it is something to do with pop up window or something.
Summary: Gecko profiler causes visible titlebar flickering. → Pop up windows can causes visible titlebar flickering.
(Reporter)

Comment 5

5 years ago
Can also be reproduced by middle clicking on a page (so that the scroll icon appears) and keeping the mouse pointer on that icon, scroll by the mouse wheel.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:20.0) Gecko/20121214 Firefox/20.0

WFM testing on Nightly (buildID: 20121214030827) + Profiler 1.10.17 using STR from comment 0 and comment 5. If someone can reproduce this please reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

5 years ago
I can still reproduce this.
After some diagnosis, i find that this is related to using a "synaptic touchpad". 
If i plug in a USB mouse, and use it in STR 0, i dont get any flicker.
But if i use the touchpad, i get flickering. 

Please also see the SPS profile in comment 1.  It shows *heavy* redrawing in the browser. So the browser is doing _something_ CPU intensive during these flickerings.  So the browser is possibly doing something silly here. 
IMO, this should be investigated further.  I politely suggest to open this again.
(Reporter)

Updated

5 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

5 years ago
QA team : Can you try to repro this issue with a laptop having a Synaptic touchpad and driver version 16.2 or later from here : http://www.synaptics.com/resources/drivers

Comment 9

5 years ago
Reproduced using a laptop with Synaptics touchpad (Driver version 16.2 and 16.3), Profiler 1.9.8, but this flickering seems to have existed at least since m-c 2012-06-05, so probably not a regression...
(Reporter)

Comment 10

5 years ago
As far as i remember, driver version 15.x did not have this issue.
(Reporter)

Comment 11

5 years ago
Ok so i have discovered the problem.

Driver version 15.x  have a option  "scroll the active window"  OR "scroll whats beneath the pointer".

If you choose "Scroll whats beneath the pointer" , this flickering can be seen. As far as i understand, whenever you try to do STR, when you scroll, the mouse focus is constantly switching between the main Firefox window, and the Pop-up overlay screen. This causes Firefox to focus/unfocus the window borders constantly, leading to visible flickering and high CPU usage.

Driver version 16.x have removed this option. The default option is "Scroll whats beneath the pointer" , which cant be changed.
(Reporter)

Updated

5 years ago
Summary: Pop up windows can causes visible titlebar flickering. → Synaptic Touchpad drivers 16.x cause window borders to focus/unfocus constantly on scrolling, causing visible flickering and high CPU usage.
Closed -> like written in comment 11 this is a function of a driver.

we are not able to override a function from an external driver inside firefox.
it's acting like a mouse, that is clicking, this can't be overwritten without lose of functionality.

pleae reopen, if it is a problem from firefox and i missunderstand the comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.