Installing a privileged signed packaged app, updating it on the server, completing the update - pulled down status bar gets stuck until you put the phone to sleep

RESOLVED DUPLICATE of bug 823213

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 823213
5 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build: B2G18 12/19/2012
Device: Unagi

Steps:

1. Install a privileged signed packaged app v1.0
2. Update the app to v1.1 on the server
3. Execute a manual sync through settings
4. When the notification for update appears, confirm the update
5. When the update completes, try to close the status bar (flick the status bar back up in other words)

Expected:

The status bar should be able to flicked upwards to return back to the app UI you were on.

Actual:

I can't flick up the status bar. The only workaround I've found so far is that if you put your phone to sleep, unlock the phone, you'll get around this issue. But otherwise, you are stuck.

Reproduced consistently twice in a row so far.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
Non blocking, but tracking. We will use this workaround.
blocking-basecamp: ? → -
tracking-b2g18: --- → -
Did you mean to set the tracking-b2g18 flag to + ? Sorry for the noise in other case, but I've seen you doing that way in other bugs (i.e. https://bugzilla.mozilla.org/show_bug.cgi?id=823189#c3).
tracking-b2g18: - → ?
(Reporter)

Comment 3

5 years ago
(In reply to David Scravaglieri [:scravag] from comment #1)
> Non blocking, but tracking. We will use this workaround.

That's not acceptable. That's basically every single update getting affected by this.

The arguments you are making make absolutely no sense - we can't just dump on one feature set. This was determined a critical v1 feature. So back into triage it goes. This definitely blocks.
blocking-basecamp: - → ?
tracking-b2g18: ? → ---
(Reporter)

Updated

5 years ago
Blocks: 823525
Jason, can you flick up the status bar after a moment ? I've noticed that when uncompressing a packaged app, the phone is unresponsive during a moment (this should definitely be fixed) but it's responsive again as soon the uncompress is finished.
(Reporter)

Updated

5 years ago
Flags: needinfo?(jsmith)
(Reporter)

Updated

5 years ago
No longer blocks: 823525
(Reporter)

Comment 5

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #4)
> Jason, can you flick up the status bar after a moment ? I've noticed that
> when uncompressing a packaged app, the phone is unresponsive during a moment
> (this should definitely be fixed) but it's responsive again as soon the
> uncompress is finished.

When I tested this originally I couldn't even do that. I think the reason why this is happening is a combination of the confirmation for install getting stuck at the bottom after we complete an install along with it overlapping the bottom of the status bar place. So the place you would use to flick up the status bar is blocked from usage, as the z-index for the confirmation takes precedence over the area you could use to move the status bar up.
Flags: needinfo?(jsmith)
(Reporter)

Updated

5 years ago
Depends on: 823213
(Reporter)

Comment 6

5 years ago
Take a look at the screenshot from https://bug823213.bugzilla.mozilla.org/attachment.cgi?id=694018. It's basically that except with the status bar down instead.
Jason, I agree with your analyse and so I resolve as duplicate.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823213
No longer depends on: 823213
blocking-basecamp: ? → ---
You need to log in before you can comment on or make changes to this bug.