Last Comment Bug 823446 - Fix 'Services.appshell', should be 'Services.appShell' (documentation was wrong)
: Fix 'Services.appshell', should be 'Services.appShell' (documentation was wrong)
Status: RESOLVED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: Trunk
: All All
: -- normal (vote)
: 2.1
Assigned To: Sebastian H. [:aryx][:archaeopteryx]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-20 02:20 PST by Sebastian H. [:aryx][:archaeopteryx]
Modified: 2013-01-12 05:28 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Change Services.appshell to Services.appShell (1.13 KB, patch)
2012-12-20 02:23 PST, Sebastian H. [:aryx][:archaeopteryx]
philipp: review+
Details | Diff | Splinter Review
Change Services.appshell to Services.appShell, r=philipp (1.17 KB, patch)
2013-01-07 10:25 PST, Sebastian H. [:aryx][:archaeopteryx]
philipp: approval‑calendar‑aurora+
philipp: approval‑calendar‑beta+
Details | Diff | Splinter Review

Description Sebastian H. [:aryx][:archaeopteryx] 2012-12-20 02:20:52 PST
http://mxr.mozilla.org/comm-central/source/calendar/resources/content/calendarService.js#119
has
w = Services.appshell.hiddenDOMWindow;
which should be
w = Services.appShell.hiddenDOMWindow;

The documentation was wrong on this :/. Upcoming patch.
Comment 1 Sebastian H. [:aryx][:archaeopteryx] 2012-12-20 02:23:11 PST
Created attachment 694289 [details] [diff] [review]
Change Services.appshell to Services.appShell

You will have to transplant the patch to comm-aurora and comm-beta.
Comment 2 Sebastian H. [:aryx][:archaeopteryx] 2012-12-31 01:32:10 PST
Fallen, if you don't want to ship this bug in a week, this needs to be fixed/reviewed as soon as possible.
Comment 3 Stefan Sitter 2013-01-04 10:29:33 PST
The file doesn't seem to be shipped with Lightning, i.e. only Sunbird would be affected.
Comment 4 Philipp Kewisch [:Fallen] 2013-01-07 01:41:40 PST
Comment on attachment 694289 [details] [diff] [review]
Change Services.appshell to Services.appShell

r=philipp
Comment 5 Sebastian H. [:aryx][:archaeopteryx] 2013-01-07 10:25:48 PST
Created attachment 698773 [details] [diff] [review]
Change Services.appshell to Services.appShell, r=philipp
Comment 6 Sebastian H. [:aryx][:archaeopteryx] 2013-01-07 10:27:49 PST
Fallen: Should this be ported to the branches?
Comment 7 Philipp Kewisch [:Fallen] 2013-01-07 11:07:37 PST
Comment on attachment 698773 [details] [diff] [review]
Change Services.appshell to Services.appShell, r=philipp

Sure, go ahead!
Comment 8 Philipp Kewisch [:Fallen] 2013-01-07 11:08:27 PST
(Its not really worth the effort to port to branches since its in Sunbird only, but it won't hurt)
Comment 9 Ryan VanderMeulen [:RyanVM] 2013-01-12 05:07:30 PST
https://hg.mozilla.org/comm-central/rev/a5ea04a91cec

Note You need to log in before you can comment on or make changes to this bug.