Last Comment Bug 823498 - Missing Message-ID header in invitation email
: Missing Message-ID header in invitation email
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: E-mail based Scheduling (iTIP/iMIP) (show other bugs)
: Trunk
: All All
-- normal (vote)
: 4.0.0.1
Assigned To: [:MakeMyDay]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-20 06:06 PST by Jan Hejl
Modified: 2015-02-26 13:54 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
ImprovedMessageHeaderSupport-V1.diff (6.01 KB, patch)
2015-02-22 06:11 PST, [:MakeMyDay]
philipp: review+
Details | Diff | Splinter Review
ImprovedMessageHeaderSupport-RegressionFix-V1.diff (3.06 KB, patch)
2015-02-23 11:31 PST, [:MakeMyDay]
philipp: review+
philipp: approval‑calendar‑aurora+
Details | Diff | Splinter Review

Description User image Jan Hejl 2012-12-20 06:06:19 PST
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121129165506

Steps to reproduce:

Create invitation with users to be notified


Actual results:

Invitation email is missing Message-ID header


Expected results:

Invitation message should have Message-ID header.
Comment 1 User image [:MakeMyDay] 2014-07-13 05:56:22 PDT
Confirming this is still an issue on current trunk.

When this get's fixed, one should consider to also add further headers as specified in the setting for the respective mail account (e.g. organization, reply-to address, returnReceipt, etc.). Adding a priority header set to the value of the vevent priority is also worth to think of. Last but not least setting a User-Agent header (prob. extend by the application name and version of Lightning) might make bug analysis little easier if related to imip/itip bugs.

The account related stuff mentioned above should also be considered to be added for mails composed for all/undecided attendees out of the event dialog.
Comment 2 User image [:MakeMyDay] 2015-02-22 06:11:23 PST
Created attachment 8567635 [details] [diff] [review]
ImprovedMessageHeaderSupport-V1.diff

This patch adds the message-id to invitation mails and adds also organizer and sender's CN (based on the identity) to the mail headers of the same.
Comment 3 User image Philipp Kewisch [:Fallen] 2015-02-22 16:07:40 PST
Comment on attachment 8567635 [details] [diff] [review]
ImprovedMessageHeaderSupport-V1.diff

Review of attachment 8567635 [details] [diff] [review]:
-----------------------------------------------------------------

::: calendar/itip/calItipEmailTransport.js
@@ +304,5 @@
>                                                               "UTF-8",
>                                                               fieldNameLen,
>                                                               Components.interfaces.nsIMimeConverter.MIME_ENCODED_WORD_SIZE);
>              }
> +            

Added some whitespaces here.
Comment 4 User image Philipp Kewisch [:Fallen] 2015-02-22 16:51:21 PST
Pushed to comm-central changeset 11bbc7e7b180
Comment 5 User image Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2015-02-23 01:06:52 PST
There is a whitespace missing at https://hg.mozilla.org/comm-central/rev/11bbc7e7b180#l1.65
> cal.validateRecipientList(aIdentity.fullName + "<" + aIdentity.email + ">");
Comment 6 User image [:MakeMyDay] 2015-02-23 03:41:40 PST
Thanks for finding this. I will do a correction.
Comment 7 User image [:MakeMyDay] 2015-02-23 11:31:46 PST
Created attachment 8568080 [details] [diff] [review]
ImprovedMessageHeaderSupport-RegressionFix-V1.diff

Regression Fix, applying on top of the already checked in patch.

Beside the correction Archaeopteryx mentioned, I removed the User-Agent header, since bug 1037978 is not yet checked in.
Comment 8 User image [:MakeMyDay] 2015-02-26 13:03:16 PST
Regression fix pushed to cc: https://hg.mozilla.org/comm-central/rev/2717b1d486cf

It still needs to be pushed to Aurora.
Comment 9 User image Philipp Kewisch [:Fallen] 2015-02-26 13:54:21 PST
https://hg.mozilla.org/releases/comm-aurora/rev/a776bf569c09

Note You need to log in before you can comment on or make changes to this bug.