Lots of struct/class warnings in MSVC caused by ForwardDeclare macros

RESOLVED DUPLICATE of bug 823080

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 823080
5 years ago
5 years ago

People

(Reporter: dmandelin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The ForwardDeclare macros always use |class|, but many of those types are declared with |struct|, so MSVC generates tons of warnings. This is annoying.

Maybe we should just change those structs to classes now? They are much more class-like anyway.
We could, certainly.  If any of these are JSAPI-visible, that'll require embedders to make the same change to avoid warnings.  I think we want to make the change eventually, so maybe we just bite the bullet and do it.

Although, to be perfectly honest, the ForwardDeclare* macros look truly awful to me, and I wonder if there's not some better way to do this that avoids this madness entirely.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823080
You need to log in before you can comment on or make changes to this bug.