Closed Bug 823645 Opened 7 years ago Closed 7 years ago

[B2G][Keyboard] Keyboard does not show for advanced HTML editors (e.g. Gmail compose)

Categories

(Firefox OS Graveyard :: General, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

VERIFIED WORKSFORME
B2G C4 (2jan on)
blocking-basecamp +
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: ahubenya, Assigned: ttaubert)

References

Details

Attachments

(2 files, 1 obsolete file)

Description:
When user attempts to compose/reply to an email from Gmail navigated through the Browser, virtual keyboard does not show up.

Repro Steps:
1. Launch Internet Browser from device
2. Navigate to www.gmail.com from URL link
3. Enter a valid username & password
4. Select "Compose" OR open existing email and tap "reply"
5. Select inside the text body area

Actual Results: Virtual keyboard does not show up, not giving user the option to compose email.


Expected Results:
User must be presented with a virtual keyboard.


Notes:
Reproduced 6/6 times on 2 accounts.
Build ID: 20121217070202
Status: UNCONFIRMED → NEW
Ever confirmed: true
defect is still reproducing with Unagi, build ID 20121231070201
blocking-basecamp: --- → ?
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Triage: QAWANTED to confirm this bug
Keywords: qawanted
Hi,
I marked this as "bb?", I confirmed this in recent build (20130101)
Pretty sure this is bug 823832? bug 823835 is a similar regression.  I looked at 20130102 build and cannot reproduce this issue.  Can you double check which build you are on please, Walter?
Flags: needinfo?(wachen)
this defect only reproduces when accessing Gmail through the browser, NOT Gmail app on Unagi. I just reproduced this on build 20130102070202
See Also: → 809757
Turns out I was the one that made the mistake.  I was looking at the email app and not the browser.  Too much on my mind I guess.

I can reproduce on the 20130102 build using the browser app.

I can also reproduce the same thing in a smaller test case : 
http://people.mozilla.com/~nhirata/html_tp/bug573447.htm
try tapping in the middle box.

It's an iframe text area.
Flags: needinfo?(wachen)
I thought I had written a bug on this before, but I can't seem to find it.
Joe,
I again confirmed this bug.


All,
It's not related with Bug 823832 and Bug 823835.
It's related with https://bugzilla.mozilla.org/show_bug.cgi?id=573447
And, just like Naoki says, it's a iframe for advanced editor.
Triage: BB+, P3, C4 - severe usability for not able to launch keyboard
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)
Not directly a Gaia issue. The failure lives in b2g/chrome/content/forms.js.

Tim do you  have time to look at it?
Component: Gaia::Keyboard → General
Flags: needinfo?(ttaubert)
QA Contact: wachen
We're getting a focus event for the contentWindow of an iframe. Gmail is doing some JavaScript magic to have some kind of HTML editor. I'm not sure how we can separate that from other windows/frames that we don't want to have a keyboard for.
Flags: needinfo?(ttaubert)
Assignee: nobody → ttaubert
Summary: [B2G][Keyboard]Email-Adhoc: Virtual Keyboard does not show up when user attempts to compose new email in body → [B2G][Keyboard] Keyboard does not show for advanced HTML editors (e.g. Gmail compose)
Keywords: qawanted
Status: NEW → ASSIGNED
Attached patch WIP v1 (obsolete) — Splinter Review
Attached patch patch v2Splinter Review
Vivien, I think you might be a good fit to review this. If you don't have time, feel free to pass it on!
Attachment #697474 - Attachment is obsolete: true
Attachment #697489 - Flags: review?(21)
BTW, the logic is all shamelessly stolen from Firefox for Android:

http://mxr.mozilla.org/mozilla-central/source/mobile/xul/chrome/content/forms.js#500
Comment on attachment 697489 [details] [diff] [review]
patch v2

Review of attachment 697489 [details] [diff] [review]:
-----------------------------------------------------------------

Lovely code ;)
Attachment #697489 - Flags: review?(21) → review+
https://hg.mozilla.org/mozilla-central/rev/79190c8b1ae5
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
defect no longer reproduces. checked on unagi build id: 20130117070201
Status: RESOLVED → VERIFIED
Resolution: FIXED → WORKSFORME
See Also: → 1144069
You need to log in before you can comment on or make changes to this bug.