AnnouncementPresenter notification not using simplified branding icon

VERIFIED FIXED in Firefox 19

Status

Android Background Services
Product Announcements
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: bnicholson)

Tracking

unspecified
mozilla20
ARM
Android

Firefox Tracking Flags

(firefox18+ affected, firefox19 verified, firefox20 verified, fennec19+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 694533 [details]
Firefox Beta 18.0 Beta 5 (Screenshot)

See screenshot.

https://hg.mozilla.org/mozilla-central/file/d81af339bb7a/mobile/android/base/background/announcements/AnnouncementPresenter.java#l53

Care enough for Beta?
This looks very broken. I imagine this is as simple as switching an image (which we are already using elsewhere), so let's please try to get it in.
Ian, which release should have the updated logo?
Assignee: nobody → bnicholson
Flags: needinfo?(ibarlow)
I know snorp was using it for the updater. I'm not sure what release (other than Nightly) that is in right now.
Flags: needinfo?(ibarlow)
(Assignee)

Comment 4

5 years ago
Created attachment 697280 [details] [diff] [review]
Use updater icon instead of launcher icon for announcements
Attachment #697280 - Flags: review?(mark.finkle)
(Assignee)

Comment 5

5 years ago
Looks like this missed the 18 cutoff date.
status-firefox18: affected → wontfix
Comment on attachment 697280 [details] [diff] [review]
Use updater icon instead of launcher icon for announcements

We should push it to aurora ASAP though
Attachment #697280 - Flags: review?(mark.finkle) → review+
brian request approval to uplift to 19
tracking-fennec: ? → 19+
(Assignee)

Updated

5 years ago
Blocks: 793053
(Assignee)

Comment 8

5 years ago
Comment on attachment 697280 [details] [diff] [review]
Use updater icon instead of launcher icon for announcements

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 793053
User impact if declined: notification icon looks bad (see screenshot)
Testing completed (on m-c, etc.): m-i
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #697280 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b37bb6f0054c
(Assignee)

Updated

5 years ago
status-firefox20: affected → fixed
Hey y'all, this code is managed in git at https://github.com/mozilla-services/android-sync.

I'll apply this patch to the git repository and everything will be fine, but please keep rnewman or me in the loop when Android services code is changing.  Thanks!
Backported to git:

https://github.com/mozilla-services/android-sync/commit/d9f3b7c73bfb055214f063c13c7dbf79680c6c12
(In reply to Nick Alexander :nalexander from comment #11)
> Backported to git:
> 
> https://github.com/mozilla-services/android-sync/commit/
> d9f3b7c73bfb055214f063c13c7dbf79680c6c12

Spoke to soon -- needed script updates to ignore the new .png file.  Try:

https://github.com/mozilla-services/android-sync/commit/fd74340cbdfcd0a3abbe4d86aafe170519b70516
Aaron: please make sure to file Announcements bugs in the right component so we can see them. Thanks! 

Thanks for the backport, Nick.
Component: Theme and Visual Design → Android: Product Announcements
Product: Firefox for Android → Mozilla Services
Version: Trunk → unspecified
Status: NEW → ASSIGNED

Updated

5 years ago
Attachment #697280 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/b37bb6f0054c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
(Assignee)

Comment 15

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/419273e2722f
status-firefox19: affected → fixed
(Assignee)

Comment 16

5 years ago
This was originally supposed to ship with 18, but missed the deadline. It's a trivial change for UI polish; see notification icon in the screenshot for what it looks like without this patch applied. Very low risk.
tracking-firefox18: --- → ?
(Reporter)

Comment 17

5 years ago
AFAIK, no way to verify this until an announcement goes out (I trust this simple enough patch though).
It's trivial to write a restartless add-on that calls into the Java code, FWIW.
If we do spin an 18.0.1, we'd consider taking this trivial fix. Engineering would have to help QA verify the fix though (or verify themselves). Tracking.
status-firefox18: wontfix → affected
tracking-firefox18: ? → +
verified against stage.  This is now using the same icon as the update notification
Status: RESOLVED → VERIFIED
status-firefox19: fixed → verified
status-firefox20: fixed → verified
Component: Android: Product Announcements → Product Announcements
Product: Mozilla Services → Android Background Services
You need to log in before you can comment on or make changes to this bug.