[B2G][Email][Settings][sync] There is no option for manual sync under email settings

RESOLVED INVALID

Status

Firefox OS
Gaia::E-Mail
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Nick Davidson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testrun 4)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 694612 [details]
no manual sync option in Synchronize menu dropdown

Unagi Build ID: 20121217070202   "related to CASE #3455

Repro steps:
1. Tap on email Icon
2. Go to mail settings by tapping gear icon and selecting email account.
3. Open Account Settings View for the test account 
4. Tap on drop down menu to the right from word "Synchronize"
 - Manual sync option is missing in drop down menu.(Only available options:  Automatic,  1 day, 3 days, 1 week, 2 weeks, 1 month, All messages.)

Expected Result:
 User is able to set the email account to be synced only manually

Actual Result:
User does not have menu option to set email account to be synced only manually.
Only available options:  Automatic,  1 day, 3 days, 1 week, 2 weeks, 1 month, All messages.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

5 years ago
UCID: email-031
https://moztrap.mozilla.org/results/case/61807/
Whiteboard: testrun 2

Comment 2

5 years ago
Reproduces on Unagi Build #20130115070201 Kernel Dec 5

Updated

5 years ago
Hardware: x86_64 → ARM

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)

Comment 3

5 years ago
There is no option to manually Sync emails.

Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9

Updated

5 years ago
Whiteboard: testrun 2 → testrun 4
(Reporter)

Comment 4

5 years ago
Created attachment 711560 [details]
Manual sync option According to mail-settings.pdf

Email settings suppose to have manual only sync options according to wire-frames in  mail-settings.pdf document.

https://docs.google.com/a/qanalydocs.com/file/d/0B_OrcSG-WXBrMTFMWm1HNTJoUWM/edit
Fixed the test case to be more clear.  The manual sync in the test case refers to just refresh button.

Closing this bug as invalid due to no longer in spec.  Since there is a refresh button, I am unsure if there needs to be a manual option.

CCing Asuth in the event that he disagrees.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.