[music] Mix page does not show artist name when music file has cover art in the ID3 tag

RESOLVED INVALID

Status

Firefox OS
Gaia::Music
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Parul Mathur, Assigned: dkuo)

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-kilimanjaro:?, blocking-basecamp:-, b2g18+)

Details

(Whiteboard: UX-P3, BerlinWW)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 694658 [details]
Mix Page with and without artist names

Test Environment:
Device: unagi phone
Build Identifier: 20121219070201
Update channel: nightly
Git commit info: 2012-12-19 15:11:47

Steps to reproduce:
1. Copy a music file onto the phone SD Card which has ID3 tags for Title, Artist, Album and Cover Art.
2. Copy another music file onto the phone SD Card which has ID3 tags for Title, Artist and Album but NO Cover Art.
3. Launch the Music App and view the Mix page.

Actual results:
1. The file that has cover art does not show the artist name in the overlay.
2. The file that does not have cover art shows the artist name in the overlay.

Expected results:
If a music file has ID3 tag for Artist, it should display in the Mix Page, irrespective of the presence of cover art.

See screenshots attached.
(Reporter)

Comment 1

5 years ago
Created attachment 694659 [details]
Music file with ID3 tags
blocking-basecamp: ? → -
tracking-b2g18: --- → +

Updated

5 years ago
Whiteboard: UX-P3, BerlinWW
(Assignee)

Updated

5 years ago
QA Contact: mozillamarcia.knous → dkuo
(Assignee)

Updated

5 years ago
Assignee: nobody → dkuo
QA Contact: dkuo
(Assignee)

Comment 2

5 years ago
Created attachment 700270 [details]
Visual design of the mix page
(Assignee)

Comment 3

5 years ago
Parul, please see the attached image and it is the latest visual design of the mix page
https://www.dropbox.com/sh/pjr6ebjxci8cty4/Gel7di2ROT/Apps/Music#f:Music_Launch_121210.png

So what you got is a correct result. That means the mix page only shows the artist/album names when there is no covert art in an album.

Since it's a correct visual design, I am closing this and mark invalid, thanks.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.