After landing 821461 new mechanism to know if the bookmark was added or not from wrappers

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
When you are in a wrapper you can view the toolbar with a star. When you click on the star, a dialog appears saying "Add Youtube" or "Add Elvis on Youtube". Well in the past there wasn't a mechanism to know if the user added the bookmark or not finally, so when he/she clicked one option, it was removed. Currently, listening to postResult we can decide if delete or not the option.

Current state:
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/wrapper.js#L143 and https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/wrapper.js#L149 we delete options and we don't know if finally the bookmark is added or not. 

Currently after landing inline activity for bookmarking we can listen to success callback and can remove the options :)

If you have any doubt please tell me
(Assignee)

Updated

6 years ago
Assignee: nobody → crdlc
(Assignee)

Comment 1

6 years ago
Created attachment 694768 [details]
Patch v1

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: no
Testing completed: 
Risk to taking this patch (and alternatives if risky): no
Attachment #694768 - Flags: review?(arthur.chen)
Attachment #694768 - Flags: approval-gaia-master?(21)
(Assignee)

Comment 2

6 years ago
Please WAIT LANDING bug 821461

I've implemented this one before landing because I starts my vacations in a couple of hours and I don't want to forget it
Hi Cristian, I am not able to review the system app. Please set timdream or alive as a reviewer, thanks!
(Assignee)

Updated

6 years ago
Attachment #694768 - Flags: review?(arthur.chen)
Attachment #694768 - Flags: review?(21)
Attachment #694768 - Flags: approval-gaia-master?(21)
(Assignee)

Comment 4

6 years ago
Better Vivien because the implemented the wrapper UI with me
Status: NEW → ASSIGNED
Comment on attachment 694768 [details]
Patch v1

Low risk changes that fix a regression.
Attachment #694768 - Flags: review?(21) → review+
You need to log in before you can comment on or make changes to this bug.