If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[USSD/MMI] Home button is not properly handled while MMI screen is shown

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: On parental leave, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

0. Open the dialer app.
1. Send an USSD message.
2. The MMI screen is opened.
3. Click HOME button.
4. The MMI screen is hidden.
5. Reopen the dialer app.
6. The dialer is shown and after that the MMI screen is shown again.
7. Repeat steps 3-5

Expected:
6.

Current: 
The dialer is shown and after that the MMI screen is opened with the an infinite "Sending" spinner.

It only happens with USSD messages, not single MMI codes (like *#06#).
(Reporter)

Comment 1

5 years ago
Nominating as bb+ since the dialer is unusable when this issue happens.
blocking-basecamp: --- → ?

Updated

5 years ago
Component: Gaia → Gaia::Dialer
Whiteboard: DUPEME
Triage: BB-, tracking-b2g18+
not a common user scenario
blocking-basecamp: ? → -
tracking-b2g18: --- → +
The problem was due to the notification of 'voicechange' events which do not cause any message change in the USSD/MMI UI (only on the header) and consequently was impeding this UI to recover its previous state in case the user clicked on the Home button or moved to any other app.
Created attachment 703365 [details] [diff] [review]
Associated PR.

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #703365 - Flags: review?(fernando.campo)
Attachment #703365 - Flags: approval-gaia-master?(francisco.jordano)
Please German, nominate first to go to triage if you think is an important bug.
Nominating as per comment 1
blocking-b2g: --- → tef?
Thanks Francisco! I was waiting to talk to Mari Ángeles but it seems it is the way to proceed. Thanks again!
blocking-b2g: tef? → -
blocking-basecamp: - → ---
Attachment #703365 - Flags: review?(fernando.campo) → review+
Comment on attachment 703365 [details] [diff] [review]
Associated PR.

a=me

Not pretty risky and it fixes a important issue in the dialer.
Attachment #703365 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+
Landed:

https://github.com/mozilla-b2g/gaia/pull/7668
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g18: --- → fixed
(Reporter)

Updated

5 years ago
See Also: → bug 853798

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.