Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Events are missing from the calendar in recent lightning nightlies

RESOLVED FIXED in 2.2

Status

Calendar
General
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bokeefe, Assigned: bokeefe)

Tracking

({regression})

Lightning 2.2
regression

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Since the 12/19/12 nightly, at least, I'm missing events from a local calendar. The error console has lots of occurrences of a TypeError:

Timestamp: 12/21/2012 8:20:22 AM
Error: [Exception... "'TypeError: accounts.Count is not a function' when calling method: [calISchedulingSupport::isInvitation]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"
location: "JS frame :: resource://calendar/modules/calUtils.jsm"

I had nothing work-related to be doing, so I whipped up a patch. I'll attach it as soon as my local test run finishes.
(Assignee)

Comment 1

5 years ago
Created attachment 694882 [details] [diff] [review]
Patch v1

This fixes both the error and the missing events on my end.
Assignee: nobody → bokeefe
Status: NEW → ASSIGNED
Attachment #694882 - Flags: review?(philipp)

Comment 2

5 years ago
There were a bunch of API changes that need to be incoporated into Lightning. Maybe there are more code places affected in Lightning. The post at https://groups.google.com/d/msg/mozilla.dev.apps.thunderbird/pPtxn8quY_M/6XdUACTQb3AJ has a short summarization of the changes.
Depends on: 820377

Updated

5 years ago
Keywords: regression
(Assignee)

Comment 3

5 years ago
I looked through the tree (well, for calendar, at least), and it looks like these were the only two changes needed. The two previous commits look to have covered the rest.
Pushed to comm-central changeset f54ccbd9d422
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2
Comment on attachment 694882 [details] [diff] [review]
Patch v1

Looks good, thanks!
Attachment #694882 - Flags: review?(philipp) → review+
You need to log in before you can comment on or make changes to this bug.