[Wrapper] double tapping home button will show the wrapper around the homescreen

RESOLVED FIXED in B2G C4 (2jan on)

Status

Firefox OS
Gaia::Homescreen
P3
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: tchung, Assigned: vingtetun)

Tracking

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 694888 [details]
screenshot

You can get the browser wrapper to wrap around the homescreen and any core apps.  This is caused after trying to double tap home button when a e.me app (or browser bookmark) is open

Screenshot.

Repro:
1) install nightly unagi build, 20121220092540
2) add a browser bookmark or e.me app to the homescreen
3) launch that bookmark or e.me app
4) double tap the system Home button.
5) Verify app exits, and the homescreen is within the wrapper

Expected;
- double tapping should kill the wrapper as well

Actusl;
- wrapper stays.  you can proceed with using the phone within the wrapper.
Assignee: nobody → alive
Triage: BB-.P4, tracking-b2g18+. 
should not block if this were the last bug before ship. doesn't block usage
blocking-basecamp: ? → -
tracking-b2g18: --- → +
Priority: -- → P4
(Reporter)

Comment 2

5 years ago
I'm going to renominate this bug for bb? triage.  this is easily reproducible, and all sorts of weird things happen once you're in the wrapper.  For example, overlays are getting confused which to focus on, and more frequent crashes occur within e.me apps that is affecting the entire homescreen.

josh also tells me that e.me guys are here this week, and might be able to look at it.
blocking-basecamp: - → ?
(Reporter)

Comment 3

5 years ago
(In reply to Tony Chung [:tchung] from comment #2)
> I'm going to renominate this bug for bb? triage.  this is easily
> reproducible, and all sorts of weird things happen once you're in the
> wrapper.  For example, overlays are getting confused which to focus on, and
> more frequent crashes occur within e.me apps that is affecting the entire
> homescreen.
> 
> josh also tells me that e.me guys are here this week, and might be able to
> look at it.

Ignore this comment, its probably more a benfrancis question, since its not just e.me apps, but also affects browser bookmarks on homescreen.
This is a bug in system app window manager I believe ;) not e.me

(In reply to Tony Chung [:tchung] from comment #3)
> (In reply to Tony Chung [:tchung] from comment #2)
> > I'm going to renominate this bug for bb? triage.  this is easily
> > reproducible, and all sorts of weird things happen once you're in the
> > wrapper.  For example, overlays are getting confused which to focus on, and
> > more frequent crashes occur within e.me apps that is affecting the entire
> > homescreen.
> > 
> > josh also tells me that e.me guys are here this week, and might be able to
> > look at it.
> 
> Ignore this comment, its probably more a benfrancis question, since its not
> just e.me apps, but also affects browser bookmarks on homescreen.
related to fix from bug 799497?  I had a similar bug reported but it was placed as a dup of bug 799497.
blocking-basecamp: ? → +
tracking-b2g18: + → ---
Priority: P4 → P3
Target Milestone: --- → B2G C4 (2jan on)
QA Contact: ben
Assignee: alive → ben
QA Contact: ben
Stealing the stealer!
Assignee: ben → 21
Created attachment 699185 [details] [diff] [review]
Patch

When you double click on the home button the window manager code calls a new setDisplayedApp(homescreen) if a transition is currently happening which results into an instantaneous stop of the transition. That's not bad but since the wrapper buttons are hidden only at the end of the transition under a transitionend event that does not work in this case. The patch simply moves the removal out of the transitionend path which is not done for the wrapper anyway.
Attachment #699185 - Flags: review?(crdlc)
please give me the branch to test, thanks
Comment on attachment 699185 [details] [diff] [review]
Patch

It is perfect because I remember the problem :) thanks a lot Vivien!!!!
Attachment #699185 - Flags: review?(crdlc) → review+
(Reporter)

Updated

5 years ago
Blocks: 856492
You need to log in before you can comment on or make changes to this bug.