[B2G] [Bluetooth] If the phone is unable to pair with the device, display the "Unable to pair with the device. Check that the PIN is correct" message

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
6 years ago
8 months ago

People

(Reporter: amaxwell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testrun 5.1, burirun2)

(Reporter)

Description

6 years ago
[B2G][Bluetooth] When phone and paired Bluetooth device are moved out of range an error messages is not displayed

Summary:
When the phone and unpaired Bluetooth device are moved out of range, while pairing, the phone does not display a message “Unable to pair with the device. Check that the PIN is correct" message.

Build ID:
20121217070202

Test Case ID:
3523

Steps To Reproduce:
1)Go to Settings > Bluetooth
2)Select a new device that is not paired form "Devices in the Area" section
3)The automatically generated PIN shown on the screen of device and the device you are trying to pair with if possible
4)Click on Pair to pair the devices

Expected:
1)Make sure Bluetooth is on
2)The Enter PIN sheet is displayed with the appropriate keyboard if needed for pairing
3)The PIN matches or the PIN showed up
4)The phone attempts to pair with the other device. If the phone is unable to pair with the device, display the "Unable to pair with the device. Check that the PIN is correct" message

Actual:
4) No message is displayed and Bluetooth device is dropped.

Frequency:
100%

Notes:
1)Occurs when device is paired and then moved out of range
(Reporter)

Comment 1

6 years ago
Also occurs on Test Case ID 3518

The following message is not displayed:
"Check that the device you're trying to pair with is in range, has Bluetooth turned on, and matches the PIN displayed on your phone"

Updated

6 years ago
Component: Gaia → Gaia::Bluetooth File Transfer
QA Contact: wachen
Looks like a Bug 813440 dup.
The patch is in central.
I think it should be promote to beta/b2g18 branch.

https://github.com/mozilla-b2g/gaia/pull/6818
(Reporter)

Comment 3

6 years ago
Issue still occurs on Unagi Build ID: 20130104070203

Steps To Reproduce:
1)Go to Settings > Bluetooth
2)Select a new device that is not paired form "Devices in the Area" section
3)Type in the incorrect PIN for the device you are trying to pair
4)Click on Pair to pair the devices

Expected Result: 
Message displayed: "Unable to pair with the device. Check that the PIN is correct"

Actual:
No message displayed

Comment 4

6 years ago
UCID: set-069
https://moztrap.mozilla.org/results/case/62767/
Whiteboard: testrun 2

Comment 5

6 years ago
Issue repros on Unagi build 20130116070204, kernel Dec 5.
(Reporter)

Updated

6 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
(Reporter)

Comment 6

6 years ago
This issue continues to occur on testrun 5.1:
Unagi RIL Build ID: 20130225070200
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3a5a27992a75
Gaia: 5691a16fff8e1403c75ed9d6f3a443b7e58198c6

Test cases:
3518 https://moztrap.mozilla.org/runtests/run/859/env/305/
3523 https://moztrap.mozilla.org/runtests/run/859/env/305/
Whiteboard: testrun 2 → testrun 5.1
Josh - Can you give a UX perspective here on UX priority?
Flags: needinfo?(jcarpenter)
Whiteboard: testrun 5.1 → testrun 5.1 [UX-P?]

Comment 9

6 years ago
UX agrees that the right solution is to display the message in comment 3: "Unable to pair with device..." This is the expected behavior. It seems like a spec is not needed here; the expected message just needs to be implemented. 

This is P1 because it's an exception case and thus egregious, especially with Bluetooth so popular in our target markets. Updated bug to P1 accordingly.
Flags: needinfo?(jcarpenter)
Priority: -- → P1
Whiteboard: testrun 5.1 [UX-P?] → testrun 5.1

Updated

5 years ago
Whiteboard: testrun 5.1 → testrun 5.1, burirun2

Comment 10

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.