Unable to launch successfully BT transferred file from notifications

VERIFIED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia::Bluetooth
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tchung, Assigned: dkuo)

Tracking

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 694994 [details]
screenshot

After a mp3 is successfully transferred via Blue Tooth, a notification appears asking to open it.  Tapping it will throw a unknown file error.

"Can not open unknown media type"

See screenshot.

However, i can launch the music app and the file is there and i can play it just fine.   triaging for bb?, just because the error is scary to the user, and they may think the transfer was unsuccessful.  But the workaround is to just load the file from the associated app directly.

logcat: 
12-21 14:05:56.013: I/GeckoDump(108): XXX FIXME : Got a mozContentEvent: desktop-notification-click
12-21 14:05:56.023: D/memalloc(10740): /dev/pmem: Unmapping buffer base:0x43e00000 size:7548928 offset:7467008
12-21 14:05:56.033: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4bd43000 size:81920 offset:6565888 fd:101
12-21 14:05:56.033: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4be1f000 size:81920 offset:7467008 fd:90
12-21 14:05:56.033: D/memalloc(10740): /dev/pmem: Unmapping buffer base:0x44800000 size:6647808 offset:6565888
12-21 14:05:56.063: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:40960 offset:5873664 fd:90
12-21 14:05:56.133: E/GeckoConsole(108): [JavaScript Warning: "XUL box for p element contained an inline #text child, forcing all its children to be wrapped in a block." {file: "app://system.gaiamobile.org/index.html" line: 0}]
12-21 14:05:56.163: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:40960 offset:7426048 fd:141
12-21 14:05:56.173: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:614400 offset:2744320 fd:146
12-21 14:05:56.223: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:40960 offset:7467008 fd:165
12-21 14:05:56.234: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4be15000 size:40960 offset:7426048 fd:141
12-21 14:05:56.254: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4bc9a000 size:40960 offset:5873664 fd:90
12-21 14:05:56.384: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:614400 offset:3358720 fd:90
12-21 14:05:56.394: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:614400 offset:3973120 fd:141
12-21 14:05:56.414: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:12288 offset:8359936 fd:173
12-21 14:05:56.414: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4ba34000 size:614400 offset:3358720 fd:90
12-21 14:05:56.424: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4b99e000 size:614400 offset:2744320 fd:146
12-21 14:05:56.434: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4bd7f000 size:614400 offset:6811648 fd:103
12-21 14:05:56.434: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4b796000 size:614400 offset:614400 fd:72
12-21 14:05:56.444: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4be1f000 size:40960 offset:7467008 fd:165
12-21 14:05:56.444: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:614400 offset:6565888 fd:72
12-21 14:05:56.454: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b700000 size:12288 offset:8372224 fd:99
12-21 14:05:56.834: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4befc000 size:12288 offset:8372224 fd:99
12-21 14:05:56.834: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4bef9000 size:12288 offset:8359936 fd:173
12-21 14:05:57.725: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30ca, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
12-21 14:05:57.725: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30ca
12-21 14:05:57.725: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30ca
12-21 14:06:20.507: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30d7, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
12-21 14:06:20.507: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30d7
12-21 14:06:20.507: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30d7
12-21 14:06:20.507: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30d8, Prog: 31000003, Vers: cf0d42a3, Proc: 00000003
12-21 14:06:20.507: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30d8
12-21 14:06:20.507: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30d8
12-21 14:06:20.557: I/ONCRPC(112): Setup RPC Call for task 4035e420
12-21 14:06:20.557: I/ONCRPC(112): oncrpc_xdr_call_msg_start: Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
12-21 14:06:20.557: I/ONCRPC(112): xdr_std_msg_send_call: Sent Xid: 44f, Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
12-21 14:06:20.557: I/ONCRPC(112): xdr_std_msg_send_call: Received Reply Xid: 44f, Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
12-21 14:06:20.557: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30d9, Prog: 31000000, Vers: fc37ad5c, Proc: 00000004
12-21 14:06:20.557: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30d9
12-21 14:06:20.557: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30d9
12-21 14:06:20.557: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30da, Prog: 31000000, Vers: fc37ad5c, Proc: 0000000f
12-21 14:06:20.557: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30da
12-21 14:06:20.557: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30da
12-21 14:06:20.577: I/ONCRPC(112): Setup RPC Call for task 4035e420
12-21 14:06:20.577: I/ONCRPC(112): oncrpc_xdr_call_msg_start: Prog: 30000003, Ver: febcbbaf, Proc: 00000058
12-21 14:06:20.577: I/ONCRPC(112): xdr_std_msg_send_call: Sent Xid: 450, Prog: 30000003, Ver: febcbbaf, Proc: 00000058
12-21 14:06:20.577: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30db, Prog: 31000003, Vers: cf0d42a3, Proc: 00000001
12-21 14:06:20.577: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30db
12-21 14:06:20.577: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30db
12-21 14:06:20.587: I/ONCRPC(112): xdr_std_msg_send_call: Received Reply Xid: 450, Prog: 30000003, Ver: febcbbaf, Proc: 00000058
12-21 14:06:20.587: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30dc, Prog: 31000003, Vers: cf0d42a3, Proc: 00000003
12-21 14:06:20.587: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30dc
12-21 14:06:20.587: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30dc
12-21 14:06:20.587: I/ONCRPC(112): Setup RPC Call for task 4035e3d8
12-21 14:06:20.587: I/ONCRPC(112): oncrpc_xdr_call_msg_start: Prog: 30000003, Ver: febcbbaf, Proc: 00000069
12-21 14:06:20.587: I/ONCRPC(112): xdr_std_msg_send_call: Sent Xid: 451, Prog: 30000003, Ver: febcbbaf, Proc: 00000069
12-21 14:06:20.587: I/ONCRPC(112): xdr_std_msg_send_call: Received Reply Xid: 451, Prog: 30000003, Ver: febcbbaf, Proc: 00000069
12-21 14:06:20.597: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30dd, Prog: 31000003, Vers: cf0d42a3, Proc: 00000004
12-21 14:06:20.597: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30dd
12-21 14:06:20.597: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30dd
12-21 14:06:20.617: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30de, Prog: 31000003, Vers: cf0d42a3, Proc: 00000001
12-21 14:06:20.617: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30de
12-21 14:06:20.617: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30de
12-21 14:06:20.617: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 30df, Prog: 31000003, Vers: cf0d42a3, Proc: 00000004
12-21 14:06:20.617: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 30df
12-21 14:06:20.617: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 30df
12-21 14:06:25.072: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4bd43000 size:614400 offset:6565888 fd:72
12-21 14:06:25.072: D/memalloc(108): /dev/pmem: Freeing buffer base:0x4baca000 size:614400 offset:3973120 fd:141

Repro:
1) install nightly unagi build 20121220092540
2) pair your device to your mac book pro bluetooth
3) Transfer a mp3 from your computer to device
4) accept the transfer screen
5) When transfer is done, tap the notification saying the file has been transferred via bluetooth
6) Verify unknown file open

Expected:
- the file is a mp3, and the notification should launch the webactivity to music player and start playing the mp3

Actual;
- unknown media type.  but if you launch the music app, you can find the song and play it just fine.
Just a note that this is from 
https://releases.mozilla.com/b2g/   20121220 build
in case that eric/gina doesn't know about this.
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Triage: BB+, C3, P3 - seem like a regression. This used to work
Eric, can you take a first look? thanks
Assignee: nobody → echou
blocking-basecamp: ? → +
Keywords: regression
Priority: -- → P3
Target Milestone: --- → B2G C3 (12dec-1jan)
(In reply to Joe Cheng from comment #2)
> Triage: BB+, C3, P3 - seem like a regression. This used to work
> Eric, can you take a first look? thanks

Unable to open a music file from notifications is a known issue. Synced with Dominic, the owner of Music app, and he will take over this.
Assignee: echou → dkuo
(Assignee)

Comment 4

5 years ago
Thanks Eric.

And note that this bug is not a regression, I was planning to fix in bug 808461, but it was a bb- bug, and closed by Ian, so my patch was postponed.
(Assignee)

Updated

5 years ago
Keywords: regression
Please send your patch in since it's bb+.
Thanks.
(Assignee)

Comment 6

5 years ago
The patch needs to be updated since it was an one-month-old patch, I will send a new one after I update it, thanks.
(Assignee)

Comment 7

5 years ago
I should send a patch before 12/28.
(Assignee)

Comment 8

5 years ago
Created attachment 696339 [details]
use a single player to open the received file
Attachment #696339 - Flags: review?(dflanagan)
Comment on attachment 696339 [details]
use a single player to open the received file

I've made a number of suggestions on github, but there are only a couple of things that I think you must fix before landing this.

1) register the activity handler from the onlocalized callback instead of onload

2) test to see if you can use the transferred blob directly without using device storage, and update bug 812098 reporting what you found.

Have you thought about what happens if this activity is launched while music is already playing?  Do you need to do anything in your code to make that work right?

Overall it looks great! r+
Attachment #696339 - Flags: review?(dflanagan) → review+
(Assignee)

Comment 10

5 years ago
David, thanks for the reviewing. I have some replies on the github comments, you might want to take a look at them.

And since https://github.com/mozilla-b2g/gaia/pull/7234 is merge, so I am closing this and mark fixed.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Verified fixed in 2013-01-01 pvt build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.