[music] "Undefined" shows in place of "Music" on the Music home screen

VERIFIED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia::Music
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: marcia, Assigned: dkuo)

Tracking

({regression, unagi})

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)
regression, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

Created attachment 695051 [details]
Screenshot of issue

Seen during testing, unagi freshly flashed device using:

Gecko: 6962039806d6
Gaia: 231effbeabc3

STR:

1. Open the Music app
2. Observe the attached screenshot

Expected: "Music" would show at the top of the page
Actual: "undefined" shows instead

Switching to the playlist or something else and back restores the name.
Triage: BB+, C3, P3 - regression on commonly used music app in the main page.
Assignee: nobody → dkuo
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C3 (12dec-1jan)
Duplicate of this bug: 824451
(Assignee)

Comment 3

5 years ago
Created attachment 695694 [details]
changeTitleText only on title exists
Attachment #695694 - Flags: review?(alive)
Comment on attachment 695694 [details]
changeTitleText only on title exists

r=me. Tested manually and nothing bad happens to the seekbar which is modified conveniently in this patch. For sure `undefined` disappears.
Attachment #695694 - Flags: review?(alive) → review+
(Assignee)

Comment 5

5 years ago
Thanks Alive.

And I am marking this fixed since
https://github.com/mozilla-b2g/gaia/pull/7184
is merged to master.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
Unagi Build ID:20130103070201 - no repro, "Music" is shown at the top of the page when launched music app
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.