Closed Bug 824222 Opened 7 years ago Closed 5 years ago

Implement SVGElement.xml{base|lang|space}

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox38 --- fixed

People

(Reporter: dzbarsky, Assigned: heycam)

References

Details

Attachments

(3 files, 1 obsolete file)

Attached patch Patch (obsolete) — Splinter Review
I don't know if we actually want these but it's easy.
Attachment #695102 - Flags: review?(longsonr)
Attachment #695102 - Attachment is obsolete: true
Attachment #695102 - Flags: review?(longsonr)
Attachment #695103 - Flags: review?(longsonr)
Summary: Implement SVGElement.xml{base|lang} → Implement SVGElement.xml{base|lang|space}
Attachment #695103 - Attachment description: Patch → Implement xmllang and xmlbase
Best ask Cameron as I think this interface is being dropped for SVG2 which is why the original bug 722097 never got landed. You're right it is much easier to implement now, though.
Comment on attachment 695103 [details] [diff] [review]
Implement xmllang and xmlbase


I thought this was going away in SVG2 Cameron?
Attachment #695103 - Flags: feedback?(cam)
Comment on attachment 695103 [details] [diff] [review]
Implement xmllang and xmlbase

So we are definitely moving away from using xml:space="" as the mechanism for changing the treatment of white space in <text> elements, but I don't think the working group has discussed the DOM attributes for xml:space, xml:lang and xml:base.  I can bring it up at the next telcon.  (My initial feeling is to avoid implementing them just to avoid encouraging people to rely on them, given they're a bit XML-y.)
I reckon I'll wait for Cameron to confer with the SVG wg before reviewing these.
Comment on attachment 695103 [details] [diff] [review]
Implement xmllang and xmlbase

Cancelling review till Cameron is in a position to say what the interface should look like in SVG 2.
Attachment #695103 - Flags: review?(longsonr) → review-
Attachment #695103 - Flags: review-
Attachment #695132 - Flags: review?(longsonr)
xmlBase is equivalent to baseURI so that makes no sense to support. We might even remove xml:base.
Duplicate of this bug: 722097
Attachment #695103 - Flags: feedback?(cam)
The SVG WG just resolved to drop these DOM properties: http://www.w3.org/2015/02/11-svg-irc#T00-55-17
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Let's remove the commented out IDL members though.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Attached file patch
Assignee: dzbarsky → cam
Attachment #8563208 - Flags: review?(bzbarsky)
Comment on attachment 8563208 [details]
patch

r=me
Attachment #8563208 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/9ae6ae84be5a
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.