Last Comment Bug 824248 - Shift+ESC should stop XHR, WebSocket, animations even when the stop button is disabled
: Shift+ESC should stop XHR, WebSocket, animations even when the stop button is...
Status: RESOLVED WONTFIX
: ux-control
Product: Firefox
Classification: Client Software
Component: Keyboard Navigation (show other bugs)
: 20 Branch
: All All
: -- enhancement with 6 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 614304
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-22 04:53 PST by Florian Bender
Modified: 2013-01-17 22:11 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description Florian Bender 2012-12-22 04:53:44 PST
Bug 614304 changed the behaviour of ESC. The previous behaviour (i. e. abort XHR and WS, any network connection) should come back with typing Shift+ESC. This behaviour is wanted by power-users and is useful in environments with restrained or expensive bandwith, among other reasons (e. g. during development). I also believe this feature should be baked into Firefox rather than being served by addon which means even more hassle and bandwith to waste. Plus, it's a no-brainer and really straightforward to implement (judging by the patch in Bug 614304).
Comment 1 Florian Bender 2012-12-22 07:00:03 PST
I'm not so sure about stopping animations. However, if this was the original, pre-20 behaviour, let's do it.
Comment 2 Justin Dolske [:Dolske] 2012-12-26 20:17:08 PST
I think this would better be implemented as an add-on. It's edge-case functionality.
Comment 3 Florian Bender 2012-12-27 15:56:37 PST
Nope, not an edge case at all (if you exclude every broadband-always-on user). Plus it's helpful for devs, too. And it's such a small patch, it barely justifies being packaged as a multi-kB addon. But I'm repeating myself …
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-12-28 11:53:30 PST
The size of the user base that could potentially benefit is not really relevant - what matters is the size of the user base that both a) could potentially benefit and b) would actually discover it. The set of people in b) would be incredibly small, but it may still be a useful mitigation for people who knew about the pre-bug 614304 behavior (again a very small minority of users, I assert).

The bar for implementing features in Firefox is higher than "just a small patch". A "multi-KB add-on" may offend your sense of efficiency, but it does not represent a practical problem for someone who'd really want this functionality. I ended up just implementing this, since it was so easy:

https://addons.mozilla.org/en-US/firefox/addon/superstop/ (pending review)
https://github.com/gavinsharp/SuperStop
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-12-28 13:39:41 PST
FWIW: the XPI is 1.8KB :)
Comment 6 Florian Bender 2012-12-29 14:03:07 PST
Thanks!

However, I still don't see it. It's a matter of adding a one-liner to the codebase so everybody can use it right away, vs. creating an addon which has to be maintained, and installed if anybody wants to use it. This is a lot of code, CPU cycles and worktime spent which could have been solved with a lot less effort for everyone. Yes, a lot of small things like this could blow up the codebase, but it'd be foolish to not include such small things which do not have a measurable cost attached to it, that enhance the experience for (at least) some users. 

Either way, thanks again for providing at least an acceptable solution.
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-12-30 13:31:50 PST
Adding every "single line" that someone might request to Firefox means we end up with a humongous testing matrix and paralysis any time we need to change anything. There's a cost to having a lot of little-known functionality hanging around that's not be obvious until you're actually tasked with maintaining a code base like this one.

The bar is much higher than "some users".
Comment 8 Willy_ Foo_Foo 2013-01-17 22:11:53 PST
I for one use it alot
& would like to see it behind about:config flag
(if you guys are hell bent on removing this important feature)
instead of an addon

Note You need to log in before you can comment on or make changes to this bug.