window.open features leave window semi-maximized

RESOLVED DUPLICATE of bug 66799

Status

RESOLVED DUPLICATE of bug 66799
18 years ago
14 years ago

People

(Reporter: jimmys, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
My web application uses window.open to spawn new windows. Those windows are
given a size to start with (550x300) but should be resizable by the user. I set
the features as follows:
width=550,height=300,scrollbars=yes,toolbars=no,resizable=yes

The window appears with the desired dimensions, but the window decoration
provided by Win32 indicates that the window is maximized, and thus I cannot
resize the window. Pressing the decoration to unmaximize it restores the window
to some other size, at which point I can maximize it.

The expected behavior is for the window to appear with the desired dimensions,
but it should also be immediately resizable without being semi-maximized.
could you provide the sample code, also, what builid are you using?
(Reporter)

Comment 2

18 years ago
T





he sample code was something like this (I don't have it on

 hand be
ca
u
s
e
 
I am out of town; if needed I can look those up when 
I
 

g

e
t
 
b
a
c
k
)
.


funct
ion
 s
paw
nWin
dow(
newu
rl) 
{
    window.open(newurl, "width=550,he
ight
=30
0,sc
rollb
ar
s
=y

e
s
,
to

ol
ba
r

s=

n
o
,re
si
z
abl
e=
y
es"
);

}

The unexpec
ted
 beha
vio
r w
as 
witne
sse
d in M
ozi
lla 0.
9 a
nd Moz
ill
a 0.9
.1 

(both on Win32).

Updated

18 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 66799 ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.