First and last link should be disabled on bug navigation when we are on the First and last bug respectively of the buglist.

RESOLVED FIXED in Bugzilla 5.0

Status

()

--
minor
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sjoshi, Assigned: sjoshi)

Tracking

Bugzilla 5.0
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Navigating buglist..


Actual results:

I am on the First bug, still the First link is enabled.
Similarly, when I am on the last bug , Last link is enabled.


Expected results:

First link should be disabled when i am on the First bug

Last link should be disabled when i am on the Last bug.
(Assignee)

Comment 1

6 years ago
Created attachment 695301 [details] [diff] [review]
Patch-v1
Attachment #695301 - Flags: review?(LpSolit)

Comment 2

6 years ago
I see nothing wrong with having them always linkified, personally. This is really minor.
Assignee: general → ui
Severity: normal → minor
Component: Bugzilla-General → User Interface
(Assignee)

Comment 3

6 years ago
IMO,there is no sense giving an extra link on the page, which does just nothing (i.e. redirecting to the same page again n again).
No matter whether its minor or even trivial. :)

Comment 4

6 years ago
(In reply to Sunil Joshi from comment #3)
> IMO,there is no sense giving an extra link on the page, which does just
> nothing (i.e. redirecting to the same page again n again).

Well, it at least lets you reload the page. Not a big deal.


> No matter whether its minor or even trivial. :)

It matters, yes. Sometimes, the code complexity or ugliness doesn't worth the effort compared to the benefit.

Comment 5

6 years ago
Comment on attachment 695301 [details] [diff] [review]
Patch-v1

r=LpSolit
Attachment #695301 - Flags: review?(LpSolit) → review+

Comment 6

6 years ago
justdave: is that something which we want to see fixed or not? Personally, I really don't care. I r+'ed the patch, because it's technically correct, but I left the bug as unconfirmed on purpose. I will let you grant/deny approval.
Flags: approval?
Target Milestone: --- → Bugzilla 5.0
I'd go for it.  It makes the user interface cleaner, and I'm all about making the UI better.
Flags: approval? → approval+
I was mentioning on IRC that it might make the code a little less complex if we had the bug IDs on hand instead of just the index into the list and the links.  Because then it would be obvious in the code when you compare the bug ID to the current bug we're displaying to decide whether to display the link.  But that's a bit out of scope for this bug.

Updated

6 years ago
Assignee: ui → joshi_sunil
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 9

6 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/bug/navigate.html.tmpl
Committed revision 8536.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.