Closed Bug 824349 Opened 7 years ago Closed 7 years ago

'@mozilla.org/base/telemetry-ping;1' does not implement nsIObserver.

Categories

(Toolkit :: Telemetry, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: glandium, Assigned: ehsan)

Details

Attachments

(1 file)

This shows up in the error console during startup:
While creating services from category 'profile-after-change', service for entry 'TelemetryPing', contract ID '@mozilla.org/base/telemetry-ping;1' does not implement nsIObserver.
Pretty sure this is due to Rafael's recent changes.  I wonder if this error means that Telemetry is somehow broken since TelemetryPing no longer implements nsIObserver?
Assignee: nobody → respindola
OS: Linux → All
Hardware: x86_64 → All
That is strange. We have:

interface nsITelemetryPing : nsIObserver 

and

QueryInterface: XPCOMUtils.generateQI([Ci.nsITelemetryPing]),

Is there a dependency somewhere on using nsIObserver directly? Doing a debug build to check it.
Your QI implementation needs to explicitly declare that it supports nsIObserver; the declaration in the IDL is not sufficient.
Attached patch Patch (v1)Splinter Review
Assignee: respindola → ehsan
Status: NEW → ASSIGNED
Attachment #696762 - Flags: review?(nfroyd)
I cannot reproduce this bug. Do I need to build it on some particular architecture or with some particular build option?
Attachment #696762 - Flags: review?(nfroyd) → review+
https://hg.mozilla.org/mozilla-central/rev/994a813dd08d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.