Add the ability to go back to scene 1 on /firefox/new-b/

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: icaaq, Assigned: jpetto)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: r+)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20121218 Firefox/20.0
Build ID: 20121218030803

Steps to reproduce:

1. Press Cmd+N to open a new browser window, then type http://www.mozilla.org/en-US/firefox/new-b/ in the address bar and press Enter
2. Click on the "Firefox, free download" button.


Actual results:

A thank you message and download dialog appears (scene 2). I find myself wanting to use the backbutton to go back to the first scene, but if I do that I will go back to the page I was on before.


Expected results:

You could check if he history API is available and push a state /en-US/new-b/thanks/ when scene 2 appears and animate back to scene 1 if the back button is clicked.

Updated

6 years ago
Component: Webdev → Pages & Content
Product: mozilla.org → www.mozilla.org

Updated

6 years ago
Blocks: 814203

Comment 1

6 years ago
What if we just added a #download (location.hash) to the end URL when scene 2 appears. Then when the user clicks back, #download would be removed and you are back at scene 1?

I would rather add a #hash to the URL instead of a /directory so that it doesn't appear to be another URL to Google or Google Analytics.
No longer blocks: 814203

Updated

6 years ago
Assignee: nobody → jon

Updated

6 years ago
Blocks: 814203
(Reporter)

Comment 2

6 years ago
(In reply to Chris More [:cmore] from comment #1)
> What if we just added a #download (location.hash) to the end URL when scene
> 2 appears. Then when the user clicks back, #download would be removed and
> you are back at scene 1?
> 
> I would rather add a #hash to the URL instead of a /directory so that it
> doesn't appear to be another URL to Google or Google Analytics.

wfm :)

Comment 3

6 years ago
Jon: What's your timeline for this enhancement?
(Assignee)

Comment 4

6 years ago
Just pushed a branch with this update: https://github.com/mozilla/bedrock/tree/firefox-new-b-824370-824356

Would love IE 6 test & a review of https://github.com/mozilla/bedrock/blob/firefox-new-b-824370-824356/media/js/firefox/new-b.js

Is there a better way to work with hash changes?

Will ask for a push to demo2 after review.
(Assignee)

Updated

6 years ago
Whiteboard: r+

Comment 6

6 years ago
Jon: Let me know when we can get these changes done as I would like to get this page live for testing. Then we are going to replace the existing /firefox/new/ page.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

6 years ago
Jon: If you cannot get to this before your PTO, we will probably go live with new-b in the meantime.
(Assignee)

Comment 8

6 years ago
Working with pmac to get last commit reviewed. Will hopefully be completed before tomorrow afternoon.
(Reporter)

Comment 9

6 years ago
Chris: Just for the record it's going to be #download-fx because of a existing #download element in the DOM.

https://github.com/mozilla/bedrock/pull/579
(Assignee)

Comment 10

6 years ago
The above PR has been merged into the firefox-new-b-back-button branch. With Isac's (awesome) refactor/QA, I think we should be good to merge https://github.com/mozilla/bedrock/pull/561 into master and test on dev.

Comment 11

6 years ago
Sounds great!

Comment 12

6 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/5d19c590859265df4b3eedfef5f42edb77737b47
Fix back button for scene 2 > scene 1. bug 824356

Add code so back button will take user to scene 1 from scene 2.
Adds '#download' hash to URL for modern browsers (IE9+).

https://github.com/mozilla/bedrock/commit/16d76768bf2dcad488325513d1bc0b22883f0b6f
Begin dl if arriving with #download in URL. Bug 824356

Two minor concerns:

- Possible race condition with pulling correct download link from
  DOM prior to window.load. Could duplicate DOM query in window.load
  to be safe.
- Install images may not be fully loaded if on slower connection. Not
  sure we can do much here.

https://github.com/mozilla/bedrock/commit/3e2b2801fda9a8471b208eff9b94b984297ddaff
Bug 824356: refactor new.js
Merged to master as you can see from c12. Hopefully we can push this out tomorrow.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 14

6 years ago
This looks to be on production now. 

pmac: has master been pushed on prod?
You need to log in before you can comment on or make changes to this bug.