Memory leaks for test_getUserMedia_basicVideoAudio.html

RESOLVED DUPLICATE of bug 802538

Status

()

Core
WebRTC: Audio/Video
P1
normal
RESOLVED DUPLICATE of bug 802538
6 years ago
6 years ago

People

(Reporter: ekr, Assigned: jesup)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia][blocking-gum+])

(Reporter)

Description

6 years ago
Run just:

test_getUserMedia_basicVideoAudio.html


Here is the leak report:

 => mAllocCount:          37007
 => mReallocCount:         4380
 => mFreeCount:           37006  --  LEAKED 1 !!!
 => mShareCount:          53428
 => mAdoptCount:           2324
 => mAdoptFreeCount:       2324
INFO | automation.py | Application ran for: 0:00:15.134760
INFO | automation.py | Reading PID log: /var/folders/b7/mdlvs2652v9ghzcwstrc6zpw0000gn/T/tmp1p0__Spidlog

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 74235

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          35     1811   511872       49 ( 3375.21 +/-  4921.32)  1089505       15 ( 3277.65 +/-  5804.61)
  44 CondVar                                        32       32       24        1 (    9.79 +/-     4.57)        0        0 (    0.00 +/-     0.00)
  96 ImageContainer                                128      128        4        1 (    2.29 +/-     1.11)       92        1 (    4.26 +/-     1.50)
  97 ImageFactory                                   16       16        5        1 (    2.78 +/-     1.39)        6        1 (    3.27 +/-     1.68)
 124 MediaEngineDefaultAudioSource                  56       56        1        1 (    1.00 +/-     0.00)       32        1 (    2.89 +/-     0.86)
 125 MediaEngineDefaultVideoSource                  80       80        1        1 (    1.00 +/-     0.00)       29        1 (    2.86 +/-     0.88)
 129 MediaStream                                   192      192        1        1 (    1.00 +/-     0.00)      690        1 (    6.26 +/-     9.65)
 130 MediaStreamGraph                               16       16        1        1 (    1.00 +/-     0.00)        0        0 (    0.00 +/-     0.00)
 132 MediaStreamListener                            16       16        2        1 (    1.33 +/-     0.58)       15        1 (    4.86 +/-     2.15)
 161 Mutex                                          24      120      473        5 (  100.63 +/-    30.12)        0        0 (    0.00 +/-     0.00)
 192 RecycleBin                                     48       48        4        1 (    2.29 +/-     1.11)       11        1 (    5.76 +/-     3.11)
 193 ReentrantMonitor                               32       96      223        3 (   50.28 +/-    19.25)        0        0 (    0.00 +/-     0.00)
 218 StreamBuffer                                   24       24        1        1 (    1.00 +/-     0.00)        0        0 (    0.00 +/-     0.00)
 233 TimeVaryingBase                                 1        3        3        3 (    2.00 +/-     1.00)        0        0 (    0.00 +/-     0.00)
 318 nsAuthURLParser                                24       24        2        1 (    1.33 +/-     0.58)    17916        1 ( 1113.26 +/-   761.45)
 327 nsBasePrincipal                                32       32      924        1 (  357.32 +/-   254.19)     8836        1 ( 1057.11 +/-   646.80)
 426 nsDOMLocalMediaStream                          56       56        1        1 (    1.00 +/-     0.00)        9        1 (    4.41 +/-     2.15)
 701 nsPrincipal                                    56       56      924        1 (  357.32 +/-   254.19)     8836        1 ( 1057.11 +/-   646.80)
 784 nsStandardURL                                 248      248     5555        1 ( 1185.89 +/-   770.69)    52224        1 ( 3097.92 +/-  1936.80)
 795 nsStringBuffer                                  8        8    41386        1 ( 9021.05 +/-  4506.33)    94814        1 (17722.06 +/-  7847.09)
 837 nsTArray_base                                   8      160    93422       20 (10830.68 +/-  5138.97)        0        0 (    0.00 +/-     0.00)
 846 nsThread                                      200      400       20        2 (    9.87 +/-     4.92)     2895        2 (  106.82 +/-    26.26)

nsTraceRefcntImpl::DumpStatistics: 973 entries
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1811 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of CondVar with size 32 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of ImageContainer with size 128 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of ImageFactory with size 16 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of MediaEngineDefaultAudioSource with size 56 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of MediaEngineDefaultVideoSource with size 80 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of MediaStream with size 192 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of MediaStreamGraph with size 16 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of MediaStreamListener with size 16 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 5 instances of Mutex with size 24 bytes each (120 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of RecycleBin with size 48 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 3 instances of ReentrantMonitor with size 32 bytes each (96 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of StreamBuffer with size 24 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 3 instances of TimeVaryingBase with size 1 bytes each (3 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsAuthURLParser with size 24 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsBasePrincipal with size 32 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsDOMLocalMediaStream with size 56 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsPrincipal with size 56 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsStandardURL with size 248 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsStringBuffer with size 8 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 20 instances of nsTArray_base with size 8 bytes each (160 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsThread with size 200 bytes each (400 bytes total)
(Reporter)

Comment 1

6 years ago
I'm not sure if this is a problem with the code or the tests, but regardless, there are some leaks

Updated

6 years ago
Blocks: 814721
Assignee: nobody → rjesup
Priority: -- → P1
Whiteboard: [getUserMedia][blocking-gum+]
I think that the first thing we should do is to fix bug 814721 which is "more" basic than this one.
No longer blocks: 814721
Depends on: 814721
Summary: Memory leaks in simple gUM mochitest scenario → Memory leaks for test_getUserMedia_basicVideoAudio.html
(Reporter)

Comment 3

6 years ago
I don't think it matters what order these are fixed in. Let's leave it to the assignee.
Will be fixed by bug 802538.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 802538

Updated

6 years ago
No longer depends on: 814721
You need to log in before you can comment on or make changes to this bug.