Install a hosted app that has a locale override that matches the device's locale - the apps permissions UI does not use localized values for that app

RESOLVED DUPLICATE of bug 824418

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 824418
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Build: B2G18 12/23/2012
Device: Unagi

Steps:

1. Go to http://jds2501.github.com/webapi-permissions-tests/
2. Install the hosted app from "Hosted App Test Case 6" or "Hosted App Test Case 7" with the phone's locale set to English
3. Go to settings --> app permissions
4. Select the app just installed

Expected:

After step #3, the localized app name should be seen. After step #4, the localized developer name & url should be seen.

Actual:

After step #3, the default app name is seen. After step #4, the default developer name & url is seen. This is incorrect - the localized app name, developer name, and developer url are supposed to be used from a locale if a locale specified matches the phone's locale.

Additional Notes:

This is definitely a v1 blocker. Why? Because the large majority (if not almost all) of the hosted apps submitted to marketplace default to using English for their default values and use a locale overrides for each target market this phone aims to hit. In short, this means our users in our target markets will be stuck with english-based install prompts for those apps, not the target locale that phone belongs to (e.g. pt-BR locale in locale override won't be used, so Porteguese won't be used in the install prompt, English would be).
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
Triage: BB+, C3, P3 - agree with additional notes in description.
Please renom if the risk to resolve this issue is way too high given the time we have
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C3 (12dec-1jan)
I wonder if I prefer to abandon the project or ship it knowing this issue ? Renominating...
blocking-basecamp: + → ?
(Reporter)

Comment 3

6 years ago
(In reply to David Scravaglieri [:scravag] from comment #2)
> I wonder if I prefer to abandon the project or ship it knowing this issue ?
> Renominating...

If we don't fix this, then pretty much every app installed from marketplace will always be in English. And there really isn't a work-around on this issue.

Firefox Marketplace 1.0's success is as critical as the on-device code. If we fail to provide an effective experience, then our apps ecosystem for the phone will fail. So yeah, I still stand to believe this is a showstopper given our target markets primarily being in a non-English locale.
Jason, can you please clarify a couple of points from your description:
1. You state in your STR "with the phone's locale set to English". Do you then change the locale to another language after installation? Does the scenario work as expected if the locale is set to another language, like Portuguese?
2. You state in actual that the default values are seen instead of the localized app values. I think you mean default strings from the app. Do you mean the default English strings that are in en-US? Can you provide a concrete example of the issue?
Flags: needinfo?(jsmith)
(Reporter)

Comment 5

6 years ago
See https://bugzilla.mozilla.org/show_bug.cgi?id=824418#c5.

Duping on bug 824418 as I've generalized that bug to fix the general problem I'm seeing.
blocking-basecamp: ? → ---
Flags: needinfo?(jsmith)
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 824418
(Reporter)

Updated

6 years ago
Priority: P3 → --
Target Milestone: B2G C3 (12dec-1jan) → ---
You need to log in before you can comment on or make changes to this bug.