Last Comment Bug 824424 - Comm-central build on OS X 10.7 busted due to parent m-c changesets
: Comm-central build on OS X 10.7 busted due to parent m-c changesets
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 Mac OS X
: -- normal (vote)
: Thunderbird 20.0
Assigned To: Mark Banner (:standard8, afk until Dec)
:
:
Mentors:
Depends on: 818861
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-23 21:00 PST by Atul Jangra [:atuljangra]
Modified: 2012-12-24 01:27 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Atul Jangra [:atuljangra] 2012-12-23 21:00:54 PST
Comm-Central build on OS X 10.7 is busted due to changesets in mozilla-central.
This was the last m-c merge: https://hg.mozilla.org/mozilla-central/pushloghtml?startID=24075&endID=24076
So I believe that some patch in this caused the problem.

Thunderbird Trunk: https://tbpl.mozilla.org/?tree=Thunderbird-Trunk
Relevant log that caused busting: https://tbpl.mozilla.org/php/getParsedLog.php?id=18233175&tree=Thunderbird-Trunk
Ryan has already closed c-c.
Comment 1 Justin Wood (:Callek) 2012-12-23 21:42:36 PST
As far as I can tell this is a regression from Bug 818861.

Directly assigning to Neil as he is a SeaMonkey driver, routinely works in comm-central and authored the corresponding m-c patch. Though this is in a .mm file not .cpp/.h
Comment 2 Atul Jangra [:atuljangra] 2012-12-23 22:26:15 PST
Thanks Callek. :-)
Comment 3 Mark Banner (:standard8, afk until Dec) 2012-12-24 01:27:40 PST
I pushed a simple bustage fix:

https://hg.mozilla.org/comm-central/rev/11754292111b

Note You need to log in before you can comment on or make changes to this bug.